none
BizTalk solution created in VS 2013 not opening in VS 2015 RRS feed

  • Question

  • We have created a BizTalk Solution in VS 2013 Premium version. Now we have upgraded the Visual Studio version to VS 2015 Enterprise version. But when opening in VS 2015 it says BizTalk Project is incompatible. I went through this MSDN article. But its says

    BizTalk server projects are not compatible with Visual Studio 2015 or Visual Studio 2013.

    We used BizTalk Server 2013 R2 for developing the BizTalk Solution. Do we need to reinstall BizTalk for solving this issue?

    Tuesday, July 12, 2016 1:09 PM

Answers

  • The only BizTalk Server available for Visual Studio 2015 will be BizTalk Server 2016 (or whatever the name will be).

    So unless you have the CTP bits for 2016, you cannot open any BizTalk projects in Visual Studio 2015!

    Morten la Cour

    • Marked as answer by Angie Xu Monday, July 25, 2016 5:54 AM
    Tuesday, July 12, 2016 1:12 PM
  • BizTalk 2016 will have support for SQL Server 2016, we don't know at this stage if it will support SQL 2014 as well for backward compatibility - https://msdn.microsoft.com/en-us/library/mt670742.aspx.

    BizTalk 2013 R2 has support for SQL 2014.

    Regarding your other question-

    We used BizTalk Server 2013 R2 for developing the BizTalk Solution. Do we need to reinstall BizTalk for solving this issue?

    BizTalk 2013R2 projects are only comaptible with Visual Studio 2013. So, you need to uninstall VS 2015 and then reinstall VS 2013.


    Thanks Arindam


    Tuesday, July 12, 2016 1:27 PM
    Moderator
  • We have created a BizTalk Solution in VS 2013 Premium version. Now we have upgraded the Visual Studio version to VS 2015 Enterprise version.

    You can't do that.  That's it.  There is no way around this.

    BizTalk Server 2013 R2 requires Visual Studio 2013.

    However, are you sure you 'upgraded' Visual Studio?  You can run Visual Studio versions side by side.  This has been supported for years.

    Most likely, all you need to do is install VS2013.

    • Marked as answer by Angie Xu Monday, July 25, 2016 5:54 AM
    Tuesday, July 12, 2016 1:31 PM
    Moderator

All replies

  • The only BizTalk Server available for Visual Studio 2015 will be BizTalk Server 2016 (or whatever the name will be).

    So unless you have the CTP bits for 2016, you cannot open any BizTalk projects in Visual Studio 2015!

    Morten la Cour

    • Marked as answer by Angie Xu Monday, July 25, 2016 5:54 AM
    Tuesday, July 12, 2016 1:12 PM
  • The only BizTalk Server available for Visual Studio 2015 will be BizTalk Server 2016 (or whatever the name will be).

    So unless you have the CTP bits for 2016, you cannot open any BizTalk projects in Visual Studio 2015!

    Morten la Cour

    Thanx for the reply. Even if we have CTP (still we dont have that since download is invite only) will it support SQL 2014?
    Tuesday, July 12, 2016 1:21 PM
  • BizTalk 2016 will have support for SQL Server 2016, we don't know at this stage if it will support SQL 2014 as well for backward compatibility - https://msdn.microsoft.com/en-us/library/mt670742.aspx.

    BizTalk 2013 R2 has support for SQL 2014.

    Regarding your other question-

    We used BizTalk Server 2013 R2 for developing the BizTalk Solution. Do we need to reinstall BizTalk for solving this issue?

    BizTalk 2013R2 projects are only comaptible with Visual Studio 2013. So, you need to uninstall VS 2015 and then reinstall VS 2013.


    Thanks Arindam


    Tuesday, July 12, 2016 1:27 PM
    Moderator
  • We have created a BizTalk Solution in VS 2013 Premium version. Now we have upgraded the Visual Studio version to VS 2015 Enterprise version.

    You can't do that.  That's it.  There is no way around this.

    BizTalk Server 2013 R2 requires Visual Studio 2013.

    However, are you sure you 'upgraded' Visual Studio?  You can run Visual Studio versions side by side.  This has been supported for years.

    Most likely, all you need to do is install VS2013.

    • Marked as answer by Angie Xu Monday, July 25, 2016 5:54 AM
    Tuesday, July 12, 2016 1:31 PM
    Moderator
  • Hi,

    This is the software required for running BizTalk Server:

    Software

    BizTalk Server 2013 R2

       BizTalk Server 2013

      Required for

    Microsoft Visual Studio

    Visual Studio 2013

    If you have Visual Studio 2013 Update 2 installed, you might find a few artifacts missing while creating a new BizTalk Server project in Visual Studio. To fix this issue, you must install Visual Studio 2013 Update 3.

    Visual Studio 2012

    Provides a development environment for building BizTalk Server applications. Ultimate Edition is recommended, but Premium and Professional are also supported.   This is required for BizTalk Server Developer Tools and the SDK.

    In addition, we can install VS 2013 and VS 2015 side-by-side.

    Regards,

    Angie


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, July 14, 2016 6:47 AM