locked
Azure Storage Explorer crashes on private network RRS feed

  • Question

  • Hi,

    I have a problem with storage explorer. We have two connections in our company where one is private and has proxies and the other one is public. I know to connect to Azure storage i have to use the public as the private one won't open it and when i connect to my Azure account via public network everything is fine, but as soon as i switch to private network even though i close Storage explorer, everything crashes after i open it. Basically, i have to uninstall and install the Storage explorer again to fix this issue. 

    If i open the application when i connect via private network, Storage explorer will open, but obviously won't get connected to the storage. Has anyone experienced this before, or has any suggestions.

    Thanks

    Thursday, January 11, 2018 1:18 AM

All replies

  • What version of Azure Storage Explorer are you using? Does this happen with the latest version 0.9.3?

    -----------------------------------------------------------------------------------------------------

    Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members.

    Thursday, January 11, 2018 5:54 AM
  • yep, i have the latest version which is 0.9.3
    Thursday, January 11, 2018 6:53 PM
  • Most likely, when storage explorer is open and you activate the private connection, it corrupts the package which have open connectivity to Azure, when the disruption is sudden. My suggestion is to configure routing/Firewall of your private connection to allow the use of storage explorer and Azure services.  
    I'd recommend checking the Proxie section mentioned here: https://docs.microsoft.com/en-us/azure/storage/common/storage-explorer-troubleshooting 
    Wednesday, February 21, 2018 7:17 PM