locked
Trouble deploying reports with VS 2008. RRS feed

  • Question

  • I'm getting errors for all of my reports when I deploy from Visual Studio.

    "The underlying connection was closed: An unexpected error occurred on a send."

     

    The images are deploying and are accessible in:

    http://localhost/ReportServer?&rs%3aCommand=ListChildren

     

    The error manifests almost immediately, so it doesn't look like a timeout issue.

    I'm using IIS virtural path, run as application/application pool, and I have removed the secure binding.

     

    Any ideas?

     

     

    I am using:

    SQL Server 2008

    Reporting Services v10.0.1442.32

    Visual Studio v9.0.30428.1 SP 1 Beta 1

    .NET 3.5 SP1

     

    Monday, August 4, 2008 11:59 PM

Answers

  • Are you the computer administrator who installed SQL Server 2008?
    What kind of Account Name for the services?

    For URL access to Report Manager you should have access to the Report Manager files.
    The fact that you cannot access Report Manager gives me the impression you have some problem with your SQL Server installation.

    Also Visual Studio SP1 is out why don't you use it?

    I have gone through some similar problems and tried to provide a more detailed explanation in my blog.
    If you find time try to review them.

    http://hodentek.blogspot.com

    • Marked as answer by mitchell007 Tuesday, September 7, 2010 6:48 PM
    Monday, August 25, 2008 1:21 PM
    Answerer
  • It would be helpful to find out which HTTP request got closed. Usually a network trace is helpful. You can obtain it using netmon. Alternatively you can try to enable System.Net logging: http://blogs.msdn.com/dgorti/archive/2005/09/18/471003.aspx.

     

    You don't have SSL configured do you? Can you make sure SecureConnectionLevel is set to 0?

    Monday, August 25, 2008 5:35 PM

All replies

  • What are your project deployment settings in Visual Studio? BTW, RS 2008 has nothing to do with IIS anymore. Usually, this exception is caused by the fact that the Report Server URL is wrong in the project properties.

    Tuesday, August 5, 2008 1:57 PM
  • The project property pages list deployment properties as such:

    OverwriteDataSources    --- True

    TargetDataSourceFolder  --- Data Sources

    TargetReportFolder ---  folder name

    TargetServerURL  ---  http://localhost/reportserver

     

    The images and shellTree.xml (resources) are being deployed successfully, and are visible in SSRS manager.

    I am still getting the following error for the datasourses and reports,

    "The underlying connection was closed: An unexpected error occurred on a send."

     

    Tuesday, August 5, 2008 10:19 PM
  • Does the report server log file show any errors?

     

    -Albert

     

    Wednesday, August 6, 2008 6:51 PM
  • Hi All,

    I got the same error while I tried to follow the reporting manager link in Reporting services manager. But there is a log file, and the error message is :

    "System.Net.WebException: The underlying connection was closed: An unexpected error occurred on a send. ---> System.IO.IOException: Authentication failed because the remote party has closed the transport stream."

    Service Account: Neither "Local System" or any domain account with administrative rights can help solving the issue.

    Can anyone help?
    Friday, August 22, 2008 6:46 AM
  •  

    WHich account are you using to run your report server service.
    Friday, August 22, 2008 5:09 PM
  • The Reports with extension RDL that you develop or, author using web server projects in the BDIS are deployed to the Report Server (nothing to do with IIS).
    You need to specify the post. If you have a IIS working off Port 80 then you should choose a different port (in the case of WIndows XP Pro) for the Report Server. It could be http://localhost:<portNO>/ReportServer for a default instance of SQL Server 2008

    The Reports with extension RDLC can be deloyed to the IIS. They cannot be deployed to Report Server as is.

    If you have IIS on port 80 and trying to access your Report Server with http://localhsot/ReportServer then try it again after stopping your IIS and refreshing everything.

    Saturday, August 23, 2008 2:54 AM
    Answerer
  • I don't have IIS installed and no other application is using this port. For the service I am using "local system" account, but I tried to use domain account with administrative rights, it does not help solve the problem.

     

    Saturday, August 23, 2008 6:39 PM
  • Try this combination;

    SQL Server 2008 RTM

    VS 2008 SP1 (not the beta).

     

    The default target URL that VS 2008 displays may not be the correct URL.

    Are you sure that your are accessing the right port?

    Do you see the Report Server databases in your Database Engine?

    Can you log on to Report Server in Management Studio?

    Sometimes it helps to restart reporting services in the Control Panel.

     

    What do you see when you access the Report Server Web Service URL from the Reporting Services Configuration Manager?

    Sunday, August 24, 2008 9:30 PM
    Answerer
  •  

    I am using VS2008 sp1beta1.

    The port i am accessing is correct 80. There is no IIS installed on the system.

    The DB is accessible.

    I connect successfuly to the Report server through the Management studio.

    I restarted RS several times, even Server restart didn't help.

    When I tried to deploy the project, the studio makes the primary folder and after that returns the same error.

    Through the Roporting Conf. Manag. I can open only web service url, but the "report manager url" isn't accessible.

     

    I can't understand how can it be posible.

    Monday, August 25, 2008 11:57 AM
  • Are you the computer administrator who installed SQL Server 2008?
    What kind of Account Name for the services?

    For URL access to Report Manager you should have access to the Report Manager files.
    The fact that you cannot access Report Manager gives me the impression you have some problem with your SQL Server installation.

    Also Visual Studio SP1 is out why don't you use it?

    I have gone through some similar problems and tried to provide a more detailed explanation in my blog.
    If you find time try to review them.

    http://hodentek.blogspot.com

    • Marked as answer by mitchell007 Tuesday, September 7, 2010 6:48 PM
    Monday, August 25, 2008 1:21 PM
    Answerer
  •  

    Ok thanks for the answers. I have a domain account with administrative rights on the server, where SQl server was installed. I'm going to take a look at the forum that you suggest. Thanks againg for the time spent.
    Monday, August 25, 2008 2:04 PM
  • It would be helpful to find out which HTTP request got closed. Usually a network trace is helpful. You can obtain it using netmon. Alternatively you can try to enable System.Net logging: http://blogs.msdn.com/dgorti/archive/2005/09/18/471003.aspx.

     

    You don't have SSL configured do you? Can you make sure SecureConnectionLevel is set to 0?

    Monday, August 25, 2008 5:35 PM
  •  

    HI,

    Here is a part of the log file, generated by system.NET tracing:

    "System.Net Verbose: 0 : [3088] Data from ConnectStream#32460611::ResubmitWrite
    System.Net Verbose: 0 : [3088] 00000000 : 3C 3F 78 6D 6C 20 76 65-72 73 69 6F 6E 3D 22 31 : <?xml version="1
    System.Net Verbose: 0 : [3088] 00000010 : 2E 30 22 20 65 6E 63 6F-64 69 6E 67 3D 22 75 74 : .0" encoding="ut
    System.Net Verbose: 0 : [3088] 00000020 : 66 2D 38 22 3F 3E 3C 73-6F 61 70 3A 45 6E 76 65 : f-8"?><soap:Enve
    System.Net Verbose: 0 : [3088] 00000030 : 6C 6F 70 65 20 78 6D 6C-6E 73 3A 73 6F 61 70 3D : lope xmlnsTongue Tiedoap=
    System.Net Verbose: 0 : [3088] 00000040 : 22 68 74 74 70 3A 2F 2F-73 63 68 65 6D 61 73 2E : "http://schemas.
    System.Net Verbose: 0 : [3088] 00000050 : 78 6D 6C 73 6F 61 70 2E-6F 72 67 2F 73 6F 61 70 : xmlsoap.org/soap
    System.Net Verbose: 0 : [3088] 00000060 : 2F 65 6E 76 65 6C 6F 70-65 2F 22 20 78 6D 6C 6E : /envelope/" xmln
    System.Net Verbose: 0 : [3088] 00000070 : 73 3A 78 73 69 3D 22 68-74 74 70 3A 2F 2F 77 77 : s:xsi="http://ww
    System.Net Verbose: 0 : [3088] 00000080 : 77 2E 77 33 2E 6F 72 67-2F 32 30 30 31 2F 58 4D : w.w3.org/2001/XM
    System.Net Verbose: 0 : [3088] 00000090 : 4C 53 63 68 65 6D 61 2D-69 6E 73 74 61 6E 63 65 : LSchema-instance
    System.Net Verbose: 0 : [3088] 000000A0 : 22 20 78 6D 6C 6E 73 3A-78 73 64 3D 22 68 74 74 : " xmlns:xsd="htt
    System.Net Verbose: 0 : [3088] 000000B0 : 70 3A 2F 2F 77 77 77 2E-77 33 2E 6F 72 67 2F 32 : p://www.w3.org/2
    System.Net Verbose: 0 : [3088] 000000C0 : 30 30 31 2F 58 4D 4C 53-63 68 65 6D 61 22 3E 3C : 001/XMLSchema"><
    System.Net Verbose: 0 : [3088] 000000D0 : 73 6F 61 70 3A 42 6F 64-79 3E 3C 47 65 74 49 74 : soap:Body><GetIt
    System.Net Verbose: 0 : [3088] 000000E0 : 65 6D 54 79 70 65 20 78-6D 6C 6E 73 3D 22 68 74 : emType xmlns="ht
    System.Net Verbose: 0 : [3088] 000000F0 : 74 70 3A 2F 2F 73 63 68-65 6D 61 73 2E 6D 69 63 : tp://schemas.mic
    System.Net Verbose: 0 : [3088] 00000100 : 72 6F 73 6F 66 74 2E 63-6F 6D 2F 73 71 6C 73 65 : rosoft.com/sqlse
    System.Net Verbose: 0 : [3088] 00000110 : 72 76 65 72 2F 32 30 30-35 2F 30 36 2F 33 30 2F : rver/2005/06/30/
    System.Net Verbose: 0 : [3088] 00000120 : 72 65 70 6F 72 74 69 6E-67 2F 72 65 70 6F 72 74 : reporting/report
    System.Net Verbose: 0 : [3088] 00000130 : 69 6E 67 73 65 72 76 69-63 65 73 22 3E 3C 49 74 : ingservices"><It
    System.Net Verbose: 0 : [3088] 00000140 : 65 6D 3E 2F 52 65 70 6F-72 74 20 50 72 6F 6A 65 : em>/Report Proje
    System.Net Verbose: 0 : [3088] 00000150 : 63 74 31 2F 52 65 70 6F-72 74 31 3C 2F 49 74 65 : ct1/Report1</Ite
    System.Net Verbose: 0 : [3088] 00000160 : 6D 3E 3C 2F 47 65 74 49-74 65 6D 54 79 70 65 3E : m></GetItemType>
    System.Net Verbose: 0 : [3088] 00000170 : 3C 2F 73 6F 61 70 3A 42-6F 64 79 3E 3C 2F 73 6F : </soap:Body></so
    System.Net Verbose: 0 : [3088] 00000180 : 61 70 3A 45 6E 76 65 6C-6F 70 65 3E             : ap:Envelope>
    System.Net Information: 0 : [3088] Connection#57924509 - Received status line: Version=1.1, StatusCode=401, StatusDescription=Unauthorized."

    Unauthorized is every attempt to get the item type.

    I suppose that after creating the root directory, for the specific project, recieves this message, when trying to get the type of the subfolder.

     

    2. The SSL is not working

    3. the value of the SecureConnectionLevel is 2

    Tuesday, August 26, 2008 1:40 PM
  • Hi,

    When I set the SecureConnectionLevel to 0 everything works just fine. I'm not sure why microsoft decided to configure the initial setings of the reporting server like this, but now it is working fine.

    Thank you all.

     

    Tuesday, August 26, 2008 2:09 PM
  • 401 responses are part of the challenge-response handshake and is not an error (unless there is a problem with the handshake).

     

    I don't know how you got SecureConnectionLevel to 2. It makes some connections use SSL, and will fail because SSL is not configured.

    Tuesday, August 26, 2008 5:27 PM
  • I can see this is an old thread, but for the sake of anyone else that comes across it:

    I had the same problem, using the URL http://localhost:8080/ReportServer. I had to change the TargetServerURL in the project properties to the exact HTTPS URL shown under Reporting Services Configuration Manager > Web Service URL. That is, I had to change the protocol to https://, the domain to the exact one (fully qualified) shown in Reporting Services Configuration Manager > Web Service URL > SSL Certificate, and the port to 8081 as shown in Reporting Services Configuration Manager > Web Service URL > SSL Port. Then it worked.

    In short, the URL that worked was:

    https://stevem.mycompany.com:8081/ReportServer
    Thursday, May 14, 2009 2:43 PM