locked
Please enable the Service Broker for this database if you wish to use notifications. RRS feed

  • Question

  • User-889466847 posted

    hi,

     I have this error with SQL2005.

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: The SQL Server Service Broker for the current database is not enabled, and as a result query notifications are not supported.  Please enable the Service Broker for this database if you wish to use notifications.

    Source Error:

    Line 48:         <clear/>
    Line 49:         <add name="AspNetSqlSiteMapProvider"
    Line 50:                      type="SqlSiteMapProvider"
    Line 51:                      securityTrimmingEnabled="true"
     

    How can I solve this problem?

    I convert my DB from SQL200 to SQL2005.

    Thanks.

    Sepid

     

    Wednesday, November 19, 2008 3:29 AM

All replies

  • User436930739 posted

     I think you need to enable service broker on your sql instance.

    Go to Programs -> Microsoft Sql Server 2005 -> Configuration Tools -> Sql Server Surface Area Configuration -> Surface Area Configuration for Features.  Locate "Service Broker" under the database engine and enable it.

    Wednesday, November 19, 2008 8:32 AM
  • User-889466847 posted

    Hi, And thanks for your reply. I used the path you said but when I click on service broker I see this sentence:

    this instance does not have a service broker endpoint.

    there is no checkbox to enable it.

    thanks alot.

    sepid

    Wednesday, November 19, 2008 2:04 PM
  • User436930739 posted

    I used the path you said but when I click on service broker I see this sentence:

    this instance does not have a service broker endpoint.

    there is no checkbox to enable it.

     

    This means the Service Broker is not installed on the server.  Visit the below links for more help.

    http://msdn.microsoft.com/en-us/library/ms166043(SQL.90).aspx

    http://msdn.microsoft.com/en-us/library/ms166067.aspx

    Thursday, November 20, 2008 12:16 AM
  • User-889466847 posted

    Hi,

    I enabled the database service broker . But when I made a change in the table of my SQlsitemapprovider.

    I can't seethe change in my menu. if I change web.config and save it again then I can see the change in my menu.

    thanks again.

    sepid

    Thursday, November 20, 2008 3:31 AM
  • User-1062158585 posted

    for enable the Service Broker for this database  use below command

    ALTER DATABASE DataName SET ENABLE_BROKER

    If it is not working then chek your database permissions  or  some database name like "DUMP" is not work

    so give databse names properly except keywords like dump,...

    Friday, March 6, 2009 4:18 AM
  • User-1032202698 posted

    The problem is that the activation of Broker Service need exclusive access to Db.

    So you have to force disconnection of all other users.

    You can easily do it with the following script:

    ALTER DATABASE [DBname] SET SINGLE_USER WITH ROLLBACK IMMEDIATE
    ALTER DATABASE [DBname] SET ENABLE_BROKER
    ALTER DATABASE [DBNAme] SET MULTI_USER 
    
    
    Bye!
    Wednesday, September 7, 2011 11:51 AM