none
Error: Adding Path in RunAsynchronous to UnAttend.xml file while customizing the image RRS feed

  • Question

  • Hi, 

    I am customizing Windows Image with 1703 build. And I wanted to add more custom colors with the process mentioned in UXWEG Guide provided by Microsoft. 

    Below is the content which is used for the same. 

      <component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <RunSynchronous>
    <RunSynchronousCommand wcm:action="add">
    <Path>cmd /c reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Themes\Accents\0\T heme0 /v Color /t REG_DWORD /d 0xffde6a10 /f</Path>
    <Description>Test1</Description>
    <Order>1</Order>
    </RunSynchronousCommand>
    </RunSynchronous>
    </component>

    Complete specialize content is as below

    <settings pass="specialize">
      <component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <RunSynchronous>
    <RunSynchronousCommand wcm:action="add">
    <Path>cmd /c reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Themes\Accents\0\T heme0 /v Color /t REG_DWORD /d 0xffde6a10 /f</Path>
    <Description>Test1</Description>
    <Order>1</Order>
    </RunSynchronousCommand>
    </RunSynchronous>
    </component>
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
          <OEMInformation>
            <Manufacturer>XXXXXX</Manufacturer>
            <SupportHours>XXXX</SupportHours>
            <SupportPhone>XXXXX</SupportPhone>
            <SupportURL></SupportURL>
            <Model>XXX</Model>
            <Logo>%windir%\system32\OEM\XXX.bmp</Logo>
          </OEMInformation>
          <ProductKey>NTRHT-XTHTG-GBWCG-4MTMP-HH64C</ProductKey>
        </component>
        <component name="Microsoft-Windows-IE-InternetExplorer" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" />
      </settings>

    While applying the above changes in UnAttend.xml file and applying the image. We are getting the below error ? 

    "Windows couldnot parse or process UnAttend answer file [C:\Windows\Panther\unattend.xml] for pass [specialize]. A component or non-list settings is specified more than once in answer file "

    Can someone please help how to resolve this issue ??


    • Edited by Vinay.K Tuesday, May 30, 2017 11:31 AM
    Tuesday, May 30, 2017 10:29 AM

All replies

  • Vinay.K

    This doesn't look like it has anything to do with customizing or programming Microsoft Project, (a project management application), which is the sole focus of this forum. I suggest you re-post to the following forum:

    https://social.technet.microsoft.com/Forums/windowsserver/en-us/home?forum=winserversetup

    John

    Tuesday, May 30, 2017 8:04 PM