locked
Oracle Entity Framework and Unable to find the requested .Net Framework Data Provider RRS feed

  • Question

  • User-374308808 posted

    I have a Visual Studio 2010 solution with an Entity Framework Data project and a MVC web site. The website works fine when debugging via Cassini, but when deployed to its own site in IIS (Even my local instance of IIS 7) it fails at any view hitting the provider. CNR.HARPS.DATA is the data project with the .edmx file. 

    [ArgumentException: Unable to find the requested .Net Framework Data Provider.  It may not be installed.]
       
    System.Data.EntityClient.EntityConnection.GetFactory(String providerString) +251

    [ArgumentException: The specified store provider cannot be found in the configuration, or is not valid.]
       
    System.Data.EntityClient.EntityConnection.GetFactory(String providerString) +10983191
       
    System.Data.EntityClient.EntityConnection.ChangeConnectionString(String newConnectionString) +641
       
    System.Data.Objects.ObjectContext..ctor(String connectionString, String defaultContainerName) +84
       
    Here is the connection string:
    <add name="HARPSDataModel" connectionString="metadata=res://*/HARPS.csdl|res://*/HARPS.ssdl|res://*/HARPS.m‌​sl;provider=Oracle.DataAccess.Client;provider connection string=&quot;DATA SOURCE=G****;PASSWORD=h*****;PERSIST SECURITY INFO=True;USER ID=HTCROYALTY&quot;" providerName="System.Data.EntityClient" />
    Monday, June 20, 2011 5:21 PM

Answers

  • User-374308808 posted

    I found the issue.  In the IIS application pool, I had to set Enable 32-Bit Applications to true.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, June 21, 2011 8:06 AM