locked
Infopath error while openning in Contribute permission mode RRS feed

  • Question

  • Hello,

    I am working with web-enabled InfoPath forms(2010) in a sharepoint 2010 server upgraded from 2007. After publishing the forms in a document library as the "system account" mode.

    i noticed that normal 'contributor' users get the following error every time they going to open a new form to fill up.


    There has been an error while loading the form.

    Click Try Again to attempt to load the form again. If this error persists, contact the support team for the Web site.

    Click Close to exit this message.

    Hide error details
    Correlation ID:c9d4c568-c9ec-4040-94f7-0635ee3bb5b1

    i failed to find anything in the application event log with this error.

    N.B. any site collection administrator doesn't get this error. 

    Any help will be appreciated.

     

    Riad.

    Wednesday, May 25, 2011 9:55 AM

Answers

  • Hello,

    you might have data connections in your form and when the user open it, due to permission issue, this error appears. there might be another case where you are accessing the external data from database and you have given rights to site collection admin only..

    Hope this clarify your situation...

     

    Wednesday, May 25, 2011 10:57 AM

All replies

  • Hello,

    you might have data connections in your form and when the user open it, due to permission issue, this error appears. there might be another case where you are accessing the external data from database and you have given rights to site collection admin only..

    Hope this clarify your situation...

     

    Wednesday, May 25, 2011 10:57 AM
  • Thanks a lot.

    after editing the permission on the specific list it works.

     


    Riyadh
    Wednesday, May 25, 2011 12:09 PM