none
Misbehaviour in data access (MSORACLIENT) since .NET Framework SP1 RRS feed

  • Question

  •  

    Hi,

     

    currently we are facing some different behaviour in our data access since installation of .NET Framework Service Pack 1.

     

    We are using MS Oracle Client to access an Oracle10g database mainly using stored procedures. We figured out two scenarios, where the database now throws exceptions when trying to access it:

     

    1. CLOB with no value

    In some scenarios we were filling a CLOB without a value (null) which worked fine prior to the upgrade. Since the upgrade we get the following error once we try to send such information: ORA-01084: invalid argument in OCI call

    Once we fill the CLOB in that situation now with DBNull.Value the problem is solved, so we have no really problem with that one.

     

    2. CLOB with large value

    In some scenarios we are filling a CLOB with a large amount of data. Almost always (but not really always) we get the following error since the upgrade: ORA-01460: unimplemented or unreasonable conversion requested

     

    We are currently really stuck on the second one and need help. At the moment we're not really sure what causes that affect and if it is a bug in Oralce or in the data provider. But we think the latter.

     

    Any help is appreciated.

     

    Kind regards,

    Michael

    Wednesday, October 15, 2008 5:24 AM

All replies