locked
Sharepoint default search not working for a site RRS feed

  • Question

  • Hello All,

    I am facing an issue in the search of a sharepoint 2007 site whose zone is Internet.
    The default sharepoint search is not working. When i crawl the content source I get a warning which says "The specified address was excluded from the index. The crawl rules may have to be modified to include this address. (The item was deleted because it was either not found or the crawler was denied access to it.)".

    Please anyone let me know how to do this. This is on our production server.

    I appreciate all responses.

    Thank You,
    sMITH
    smith

    • Edited by Smithspd Wednesday, May 18, 2011 5:19 PM
    Wednesday, May 18, 2011 4:09 PM

Answers

  • Hi,

     

    According to your description, as of Windows Server 2003 SP1 and beyond, including Windows Server 2008, Microsoft added a loopback security check to prevent reflection attacks on applicable machines. As a result, indexing alternate mappings (or sometimes default mappings) in SharePoint can often lead to this error, which means your documents are not indexed and therefore not searchable. Please following these steps to fix resolved your issue:

    Go to Start-> run-> regedit

    Backup your registry before beginning.

    Navigate to

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0

    Right-click on MSV1_0, select new, and then Multi-string value

    Enter the name BackConnectionHostNames and press enter

    Right-click on BackConnectionHostNames, and select Modify

    In the text box, enter a separate hostname on each line. We added a number of them as we have multiple SharePoint sites with individual domains. Some examples may be sharepoint.mydomain.com, mysites.sharepoint.com, machine-name.sharepoint.com.

    Quit the registry editor, and restart the IISAdmin service.

    After running a new Full crawl, our issue was resolved.

    I hope it can help you little.

     

    Best Regards
    David Hu

     

    • Marked as answer by Emir Liu Friday, May 27, 2011 1:42 AM
    Friday, May 20, 2011 1:51 AM