Cannot Install .NET Framework 4 - Windows 7 Home Premium - No signature was present in the subject RRS feed

All replies

  • Just tried to install .NET Framework also.  I have two Win 7 machines.  One worked fine.  The other gave the same error message.  I did not get the blue screen. 
    Saturday, June 2, 2012 12:44 AM
  • Unfortunately, that's no the log we need to see.

    Please provide a complete set of install logs as follows:

    Please collect your install logs with this:

    After you run Collect.exe, you'll find in your %temp% directory. Please upload to a public site, like SkyDrive, and post the link here.

    Saturday, June 2, 2012 1:13 PM
  • Man, why bother having a logfile that can't debug?

    Anyway, here's the other set:!107

    • Edited by A Viescas Sunday, June 3, 2012 5:37 AM hyperlink change
    Saturday, June 2, 2012 2:38 PM
  • In addition to the error you cited: "No signature was present in the subject.", this appears in the logs:

    "A file that is required cannot be installed because the cabinet file C:\windows\Microsoft.NET\Framework64\v4.0.30319\SetupCache\Extended\netfx_extended.mzz is not digitally signed.  This may indicate that the cabinet file is corrupt."

    I also note several install attempts without cleaning your %temp% directory.

    Although you may feel the effort is redundant, it may help to follow this sequence:

    Follow these steps exactly:

    Before trying to install .NET Framework 4.0, execute this command from an ELEVATED Command Prompt provided by the .NET Framework Team:

    "This issue is likely caused by a bad ACL on assembly\tmp folder. After installing updates, the ACL propagates to installed assembly folders in both 4.0 & legacy GAC.  If those updates were installed by WU or another user, the propagated ACL will prevent install of the same assembly by the current user.

    A work around would be to reset the ACL on GAC dirs.

    for /F %D in ('dir %WINDIR%\assembly %WINDIR%\Microsoft.NET\assembly /s /b /a:d') do takeown /F %D && icacls %D /reset /T"

    After running that command, follow these steps:

    Please follow these instructions exactly:

    1. Download a fresh copy of the standalone installer for .NET Framework 4.0:

    2. Also, clear your %temp% directory and disable your AV software.

    The %temp% directory is a reference to the Temp folder associated with the current user. To clear it, do the following:

    Sign on to your system with the Administrator user account you will use to run the installer. Click the Start Orb and type %temp% in the search box. The search results will show the Temp folder you want. Click on the Temp folder to open it in Windows Explorer, then delete the entire contents.

    3. Run the standalone installer from step 1 As Administrator.

    Note: Just using an administrator account is NOT enough. To activate full privileges, you must right-click the installer, then select Run as administrator.

    If the install fails, provide complete install logs as follows:

    Please collect your install logs with this:

    After you run Collect.exe, you'll find in your %temp% directory. Please upload to a public site, like SkyDrive, and post the link here.

    Sunday, June 3, 2012 1:10 PM
  • Okay. I tried all that and got the same error. Here are the logs, and here is the output of the takeown command.

    Also as a note, I couldn't totally clean out the Temp Dir due to some files used by Windows Explorer/Google Drive, but got everything I could.

    Sunday, June 3, 2012 10:42 PM
  • Hi AViescas,

    Welcome to the MSDN forum.

    Your error 0x800B0100 may occur if the Windows security .dll files are registered incorrectly.

    From your event logs

    "{ED855524-EC64-4987-8CA2-05EC107516BE} 2012-06-01 16:42:02:884-0400 1 161 106 {071ADFE6-D0AC-4600-A7B0-45D90C648BDD} 103 800b0100 AutomaticUpdates Failure Content Download Error: Download failed."

    Also some components failed to download or fail to update.

    Please refer to this article

    When you met the same error, you can try solutions listed there to fix.

    In case your OS version is Win 7 x64, expand the "Windows 7, Windows Vista or Windows Server 2008." title 

    Try the following workaround:

    Use the System Update Readiness Tool to resolve this issue. This tool will scan you computer for inconsistencies that may cause errors to occur. To run the System Update Readiness Tool, follow these steps:
    1. In the table below, click the download link that matches your version of Windows . If you're unsure of which version of Windows you are running, follow these steps:
      1. Click the Start button, then type msinfo32 in the Search box. Click msinfo32.
      2. Your version of Windows will be listed next to OS Name and your file type (x64 or x86) will be listed next to System Type.
    2. Choose the appropriate language in the Change Language list, and then click Download.
    3. When you are prompted to do so, click Run to start the installation.
    4. Follow the onscreen instructions to install the System Update Readiness Tool.

    Then run the fixit available in the link below to reset windows update components.

      How do I reset Windows Update components?

    After that, please reinstall .NET Framework 4 and if failed, show us the logs again.


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    Monday, June 4, 2012 5:57 AM
  • Downloaded the System Update Readiness Tool. Upon opening it, I got the following error:

    "Installer encountered an error: 0x800b0100"

    "No signature was present in the subject."

    Please advise.

    Monday, June 4, 2012 7:43 PM
  • I'm not trying to upstage Barry here, but this is the same message you got when trying to install .NET 4, correct?

    Given that you now have demonstrated issues beyond .NET Framework installation, I'd be considering an OS reinstall in your situation.

    Crude, I acknowledge, but perhaps the quickest solution.

    Tuesday, June 5, 2012 1:58 PM
  • Quickest in terms of time, or quickest in terms of effort?

    Spending the day reinstalling everything for the sake of one program does not exactly sound "quick."

    Wednesday, June 6, 2012 2:57 AM
  • Hi A Viescas,

    Reinstall the OS will be our last sort to solve the problem.  Actually, only with you error code we can hardly reproduce your issue,  it looks like there are multiple reasons that can cause this kind of error and not all of them are connected to .NET 4 directly. So MVP means that it will save your time if you re-install your OS. 

    I list some possible reasons and some possible solutions which you can have a try.

    First your issue here means there is something wrong with the certfication revocation.

    So we have to clarify these two things: 1. Have you ran your installation with Admin privilege 2. Have you disabled AV software

    After that, let's try these to fix this issue:

    1.  Download the full stand alone setup package from here:
    2.  Open a command line and extract the package to a local folder using the command: dotNetFx40_Full_x86_x64.exe /x
    3.  To make sure that the netfx_Core_x86.msi is digitally signed, open the folder (in windows explorer) where you extracted the package, right click on netfx_Core_x86.msi file and select ‘Properties’. You should see a “Digital Signature” tab showing that the file has been signed by Microsoft Corporation.
    4.   Now wait for a while so that the Anti-virus scans all extracted files. Alternatively, you can force anti-virus to scan the folder where you extracted the package; so that it doesn't lock these files anymore. See you anti-virus help to find out how to do it.
    5.     Now, using elevated command prompt, go to the folder where you extracted the package and issue this command: Setup.exe /x86 /x64

    But I guess this workaround may do no efforts because you failed with System Update Readiness Tool too. This may indicates that the publisher was removed or reset from your OS. I referred to this article for detail

    You will see that this kind of issue at last due to registry key modified:

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\WinTrust\Trust Providers\Software Publishing]

    For this, you can go to your control panel --> internet options --> advanced TAB --> Security section and clicked the "Check for publisher's certificate revocation".Try it on both "ON" and "OFF" after you deleted the reg key altogether before install .NET 4.

    Or just modify it to 0x0002300 as default. But first you need to show us if it has been modified.

    Please show me your updates.


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    Wednesday, June 6, 2012 10:00 AM
  • Okay, thanks for your help.

    As you said, I followed the extraction steps and got the same result (I have been running as admin/disabling AV btw); the digital signature was also present.

    When I went into the registry, I found at the location you indicated that there is one key called "State." Its value is "0x00023c00 (146432)." Is this normal?

    Wednesday, June 6, 2012 4:17 PM
  • Hi A Viescas,

    Yes ,that value is normal value and didn't need to be modify.

    So that here are some other possible solutions:

    1. Install certification to .NET 4.

        Please right click the installer>> Properties>>Digital Signature>> Details>>View Certificate  If the certification is invalid, try install certificate button and install the certificate to the software.

    2. Try to build a new user account with admin privilege.

        It is possible that the user account is corrupt. So try to build a new user account then install the software to see if this can be fixed.

    In case that you even failed with the scan tool, would you please try some other installers(Not .net 4 but any other software) to see if the error still occur.

    If you have any updates, please feel free to let me know.


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    Thursday, June 7, 2012 9:49 AM
  • Thanks for that information!

    When I viewed the digital signature details, I noticed that there was a little red "x" on the certificate's icon, as well as the error "No signature was present in the subject." 

    However, clicking "Install Certificate" and going through that process did not seem to fix it.

    As a side note, building a new user account did not fix the problem, and since the Framework install failed I have since installed Picasa 3 and Media Player Classic on my machine, both of which went off without a hitch -- which makes sense if this is a certificate error.

    Please advise further.

    • Edited by A Viescas Thursday, June 7, 2012 5:42 PM misspoke
    Thursday, June 7, 2012 5:39 PM
  • Hello A Viescas,

    The Error in your latest log is

    Final Result: Installation failed with error code: (0x800B0100), "No signature was present in the subject. " (Elapsed time: 0 00:02:19).

    Checking the WindowsUpdate.log (log used by WUSA.exe) you can find:

    2012-06-03          18:24:20:742       116        890         Misc       Validating signature for C:\windows\SoftwareDistribution\ScanFile\7cb13438-34ee-40ac-9808-79d4ec39f48b\

    2012-06-03          18:24:20:743       116        890         Misc       WARNING: Error: 0x800b0100 when verifying trust for C:\windows\SoftwareDistribution\ScanFile\7cb13438-34ee-40ac-9808-79d4ec39f48b\

    2012-06-03          18:24:20:743       116        890         Misc       WARNING: Digital Signatures on file C:\windows\SoftwareDistribution\ScanFile\7cb13438-34ee-40ac-9808-79d4ec39f48b\ are not trusted: Error 0x800b0100

    Can you try renaming the C:\Windows\SoftwareDistribution folder and trying again? 

    I am thinking that your bug check (blue screen) interrupted an installation of the Windows update and this left WU's datastore/package-cache in an inconsistent state.  It may be trying to used a cached file that is corrupt.

    Hope this helps,


    Friday, June 8, 2012 2:34 AM
  • Thanks for your reply. Unfortunately, renaming the folder and letting it regenerate did not fix the problem. Even after redownloading the installer, the certificate still says it doesn't have a signature and I get the same error when starting the installer.

    (also for some reason the certificate also expired last year. I don't suppose that has anything to do with it?)

    Friday, June 8, 2012 3:52 AM
  • Certificates expire all the time.  The signature should be timestamped before the expiration date which makes it valid.

    You may be experiencing the problem mentioned in this KB:  You can try downloading the tool provided to fix WindowsUpdate.

    After doing so try installing the update directly:

    I suggest enabling CAPI logging when installing which should prvide more detailed tracing than what you see in the WindowsUpdate.log.

    Run the following commands:
    wevtutil sl Microsoft-Windows-CAPI2/Operational /e:true
    wusa Windows6.1-KB958488-v6001-x64.msu
    wevtutil sl Microsoft-Windows-CAPI2/Operational /e:false
    wevtutil epl Microsoft-Windows-CAPI2/Operational capi_events.evtx

    If the update fails you can inspect the c:\Windows\WindowsUpdate.log to ensure it has the same error, then capi_events.evtx to detemine why the error occured.


    Friday, June 8, 2012 4:18 PM
  • As I mentioned four days ago, I am unable to run the Windows Update Readiness Tool.

    In addition, as per my first post, I am not trying to install an update for .NET 3.5 -- I am trying to install .NET 4 from scratch.

    Friday, June 8, 2012 5:21 PM
  • Any other ideas? I can turn on CAPI logging but wusa (obviously) won't work with a new installer.
    Tuesday, June 12, 2012 7:55 PM
  • Hi A Viescas,

    I'm trying to involve some more experts on your issue.


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    Thursday, June 14, 2012 4:25 AM
  • Okay, so I turned on CAPI logging and ran the installer. Here is a link to the event file:!110

    PS: I seem to be having trouble with Windows Update in general, not just .NET. So let me know if there's a better place I can post this issue.
    • Edited by A Viescas Thursday, June 21, 2012 6:52 PM
    Thursday, June 21, 2012 6:48 PM
  • Anyone? Is this log useful or not?
    Thursday, July 5, 2012 10:02 PM
  • Hope this wasn't forgotten...
    Tuesday, July 17, 2012 1:38 AM
  • Hi,

    We checked log and found the error,

    File netfx_Core.mzz (C:\windows\Microsoft.Net\Framework64\v4.0.30319\SetupCache\Client\netfx_Core.mzz), failed authentication. (Error = -2146762496). It is recommended that you delete this file and retry setup again.
    [6/1/2012, 16:41:57]Failed to verify and authenticate the file -C:\windows\Microsoft.Net\Framework64\v4.0...\netfx_Core.mzz

    Please try to use command  "dotNetFx40_Full_x86_x64.exe /x" in cmd console to extract the package, and use the command like

    c:\path\netfx_Core_x64.msi EXTUI=1

    to install .net 4.

    Also, you could  visit the below link to see the various paid support options that are available to better meet your needs if you requires a more in-depth level of support.;en-us;offerprophone

    Tuesday, July 17, 2012 9:43 AM
  • Hi, thanks for the response.

    Upon following those steps, I got the following error:

    "A file that is required cannot be installed because the cabinet file C:\Users\Amber\Downloads\dotNetFolder\netfx_core.mzz is not digitally signed. This may indicate that the cabinet file is corrupt."

    (even after downloading the package again)

    As every failure I've gotten is an authentication failure, and because the Microsoft Certificate on my computer looks like this, I believe this isn't a problem with .NET but with something gone horribly wrong with the authentication certificate for Microsoft. Would it be better to move this post or make another one in a relevant forum?

    Wednesday, July 18, 2012 6:04 PM