Internet Explorer 11 & SSRS ReportViewer RRS feed

  • Question

  • I just happened to notice that the SSRS reportviewer print command button which is an ActiveX control is no longer visible after installing IE11. Does anyone have experience the same?

    Microsoft, can you provide any ideas/solutions?

    • Edited by IngallsMIS Wednesday, November 13, 2013 10:17 PM
    Wednesday, November 13, 2013 10:17 PM

All replies

  • I would like to know the solution for this as well. Can't find one piece of documentation about the report viewer and IE11 browser compatibility.
    Thursday, November 14, 2013 6:05 PM
  • We face the same problems. The clients which upgraded from IE 10 to IE 11 do not see the print button.

    We upgraded from ReportViewer 10 to 11 but the problem remains. The issue has for us high importance.

    Tuesday, November 19, 2013 11:39 AM
  • This issue continues.. we downgraded our users for time being until a fix is available.

    The functionality is restored back when in "developer tools" and emulating IE 10 but once the browser is back in regular mode, issue remains.

    Running the page in compatibility mode restores the print icon image BUT no print action is triggered on click event.

    Still trying to figure this out....

    • Edited by IngallsMIS Tuesday, November 19, 2013 3:31 PM
    Tuesday, November 19, 2013 2:30 PM
  • Any news on this?

    Print button is still not available for IE11.

    Wednesday, November 20, 2013 9:59 AM
  • Microsoft please give us a fix for this issue!
    Friday, November 29, 2013 4:36 PM
  • Same problem here. Even when run AT THE REPORT SERVER the report toolbar is messed-up (vertical instead of horizontal) and print button missing. What is Microsoft doing!?!? They keep breaking their own products!


    Monday, December 2, 2013 2:49 PM
  • The problem persists. Also, when I add a horizontal line in reports, nothing appear. But, if the line is not horizontal, it's ok...
    Monday, December 2, 2013 6:32 PM
  • Come on Microsoft. Do you guys ever test anything? You can't even get your products to work with each other. Nice Research team!
    Tuesday, December 3, 2013 1:50 PM
  • You'll love this one.  I am using IE 11. VS 2013 ReportViewer version 11.  When running the site in my development environment with IIS Express I can see the print button.

    I deploy to my server (Win 2008 Server R2) and browse to the site with IE 11 .... no print button.

    The server has IE 8 on it.  I can browse to the site with IE 8 on the server and I can see the print button.

    I am going to try and install the latest redistributable for Report Viewer 2012 on the server tonight and see if that helps.


    Tuesday, December 3, 2013 11:00 PM
  • Installing the report viewer 2012 redistributable from the link above did the trick on my server!
    Wednesday, December 4, 2013 5:52 AM
  • @rldawg. This did not help me. The version of Report Viewer from the link is 11.0.2802.16, which is from the year 2012.
    Wednesday, December 4, 2013 12:03 PM
  • Actually if you look at this:


    It was released on 10/14/2013

    The version installed is 11.0.3366.16

    Wednesday, December 4, 2013 7:14 PM
  • rldawg is correct, there is a newer version.
    What helped me at the end was to run Windows Update and run all updates.
    Friday, December 6, 2013 12:19 PM
  • The server. The website is serving up the report viewer control.
    Sunday, December 8, 2013 12:24 AM
  • All I did is run the redistributable above.  I had done all windows updates prior.  I had also installed .NET 4.5.1 on the server but I have no clue if that has any bearing or not.  I am just stating what my server has installed.
    Sunday, December 8, 2013 12:43 AM
  • I was able to see the print button after I switched the page to compatibility view.
    Monday, December 16, 2013 2:43 PM
  • In my case, deploying the updated SSRS version had no impact but I have another weird IE11 issue.  After deploying the fixed ie.browser (for .NET 4.0) in App_Browsers everything got fixed for me in a production environment but in IIS Express the toolbar of the reportviewer renders incorrectly (buttons in 5 rows instead of 1) unless I force the site into compatibility view.  In production, compatibility view is not required... and I can't for the life of me figure out what the difference is.

    Another odd thing is that even though I verified the assembly versions of the report viewer control in the bin folder of the web application (we do not use the GAC) I noticed that the html that gets outputted by the control still contains some references to version that match the old control version.

    Seriously, why is it that I have always had the worst time getting the report viewer control to render correctly in Microsoft's own browser?!  I had hopes that upgrading to the 2012 version of the control would alleviate all of the browser issues of the older one but if anything it has been worse. 

    Tuesday, December 17, 2013 6:44 PM
  • Same issue here.

    When we found that SSRS 2012 had compatibility problems with IE10 until we installed SQL Server 2012 SP1 I thought Microsoft would avoid a repeat of this scenario, but evidently not.

    Thursday, December 19, 2013 4:35 AM
  • A couple of people have mentioned the navigation toolbar appearing over multiple rows issue. I have just added a workaround to the connect bug which doesn't require compatibility mode. Unfortunately it doesnt correct the print control issue.


    Tuesday, January 28, 2014 1:21 AM
  • I could solve the problem by adding the site in "Mode compatibility" in tools menu
    Tuesday, January 28, 2014 2:24 PM
  • Is there any other way without adding the site in  compatibility view we can show the print button in IE11,

    Like if we can add any thing in meta tag or any header tag in IIS that make the page in compatibility mode?

    or any other solution?

    Thursday, January 30, 2014 11:28 AM
  • This has been fixed in SQL Server 2012 SP1 CU8. http://support.microsoft.com/kb/2917531 (Feb 2014)
    Thursday, April 10, 2014 1:36 PM
  • Hello,

    I am facing same issue in IE 11, Report view toolbar is not showing as expected, all report look as white background.

    If you have resolved this issue, then please help to resolve IE 11 issue.


    Monday, April 14, 2014 5:27 AM
  • We installed this, but it didn't fix anything.  I don't see that this issue is listed as one fixed by the SP1 Cumulative Update 8.
    Saturday, April 26, 2014 10:14 PM
  • I wondered the same thing, I read the kb article for SP1 CU8 and could find no mention of IE11 compatibility.

    Mariusz Cichomski at Microsoft specifically states this fixes the problem here:

    Another person indicates that it fixes the issue in SQL2012 but not SQL2008R2.

    We are running SQL2012 SP1 and haven't installed CU8 (or CU9 for that matter) on servers yet. I am considering waiting for SP2 which is apparently due "this year".

    Sunday, April 27, 2014 10:10 PM
  • This may or may not help anyone, but I thought I'd throw it out there in case it does. I had an issue where IE11 broke printing from an SSRS 2008 server. The prompt would come up to install the Active X component, select yes then IE would close. Since I also have a SSRS 2012 server I tried printing from there and the Active X control installed without issue. I then went back to the 2008 server and had no issues printing as expected because backward compatibility should have been in place. This worked out well as I couldn't just go and throw patches or tweaks at a prod box.
    Tuesday, May 6, 2014 4:04 PM
  • There is my workaround: adding  <meta http-equiv="X-UA-Compatible" content="IE=edge"/> page header with ReportViewer control:

        <meta http-equiv="X-UA-Compatible" content="IE=edge"/>

    But with "IE=edge" there is no possibilities to print report, so I change it to "IE=9":

        <meta http-equiv="X-UA-Compatible" content="IE=9"/>
    Thursday, July 17, 2014 6:39 AM
  • Hi Ace,

    We had a similar scenario at client system running Win7/IE11 for the SSRS 2008 R2 with Report Viewer 10 print control not working for the functionality.

    We had to install the SSRS 2008 R2 latest service pack and SSRS Report Viewer 10 Control Service Pack update. It works fine for them now.

    Hope this helps.



    Mitulkumar Brahmbhatt | Please mark the post(s) that answered your question.

    Wednesday, October 22, 2014 10:27 PM
  • Hello Mithul,

    Please provide the links to download both the updates.

    1. SSRS 2008 R2 latest service pack and 

    2. SSRS Report Viewer 10 Control Service Pack update

    Thank you and I would really appreciate your help.



    Friday, November 21, 2014 8:06 PM
  • if you use reportviewer embedded in a page hosted by iis you can try this workaround:
    1) download url rewrite module for iis
    2) enable HTTP_USER_AGENT as Server Variable
    3) Write a Rule that change HTTP_USER_AGENT in "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)"
    for pages that hosts ReportViewer.
    That do the trick
    Thursday, November 27, 2014 8:54 PM
  • This is my exact issue. I'll try this and let you know how it works out. 

    Thanks for sharing.

    Wednesday, December 3, 2014 8:15 PM
  • This worked for me, although not quite the same solution.

    I had a more up to date 2008 R2 server (my local instance) actually. Pointed IE11 at it. Successfully installed the Active X control, and now printing works like a champ.

    Again, thanks for sharing and spelling out your issue.

    Wednesday, December 3, 2014 8:25 PM
  • Hi Praveen,

    Sorry for the late response as I was not following up on the thread here.

    Please find the respective links as followed:

    1. SSRS 2008 R2 latest service pack and 


    2. SSRS Report Viewer 10 Control Service Pack update


    I believe this would help in case you have not found the same :)

    Mitulkumar Brahmbhatt | Please mark the post(s) that answered your question.

    Tuesday, December 16, 2014 3:57 PM
  • ** 2015 Fix **

    I experienced this same issue and worked many hours with Microsoft Tier II until we finally got to the root cause and correct solution.  I've blogged about my experience here, including detailed fix:


    • Edited by msigman Friday, February 27, 2015 9:43 PM
    Friday, February 27, 2015 9:42 PM
  • @Vladislav Osmanov-We tried that too but that didn't work and we can't install framework update ..i think the only solution we have is to export the report to pdf  on  button click ..can you suggest some other solution?

    Wednesday, December 23, 2015 9:02 AM
  • Pretty sad that Microsoft cannot fix it's own problems.  Just wait until you try the Edge browser in Windows 10...same problem. I heard that it is because ActiveX is no longer supported but shouldn't there be a workaround immediately?  It is keeping me from going to Win 10 and even all of our development customers.
    Monday, December 28, 2015 6:35 PM
  • It appears that this issue will be addressed in SQL Server 2016 with a solution that does an implicit export to PDF and, if possible, puts the user straight into a print dialog:


    I know an upgrade to 2016 isn't going to be feasible for everyone as a fix for their current issue, but I'm pleased to hear that MS is still keeping SSRS users in mind as we try to maintain compatibility with the OS/browser world.

    Sunday, January 10, 2016 11:42 PM
  • We have tried everything mentioned here...the 4.5.1 update and the browser file but neither works on our clients 2008R2 server with IE11 on workstations.
    Tuesday, January 12, 2016 2:00 PM
  • I had the same issue with everyone else using SQL Server 2008R2 and IE11.
    In order to get this to work here are the steps I used.

    1.  Go to Setting > Compatibility View Settings

    2.  On the "Compatibility View Settings" window add the URL for the website. Then close.

    3.  Refresh SSRS report so that the "Print" icon now appears.  

    4.  On pop up: "Message from WebPage" - Unable to load client print control >  Click OK

    5.  Click Install on the new window to install the add-on 'SQL Server Reporting Services 2008R2'

    6.  Rerun the report and then click the "Print" button.

    7.  On the new window.  Click Install.

    8.  You should now be able to print.  

    Hopes this helps


    Tuesday, February 9, 2016 8:21 PM
  • Only 1 problem.  I do not want to run in compatibility mode on this website.  We run ours just fine without compatibility mode on and I want our client website to do the same.
    Tuesday, February 9, 2016 9:10 PM
  • Hello everyone,

    I have found a solution for this problem, here goes the folowing, either by group policy or by individual configuration on each IE, just add the report site to the Local Internet Zone in the security tab.


    And everything should be ok... It is all to do with security policies....

    Monday, February 22, 2016 1:24 PM
  • Did nothing for me...still a problem!  Not sure about everyone else but I DO get a print icon but when I click it, nothing happens.  I get a spinning wait wheel but nothing ever pops up to select a printer.
    Monday, February 22, 2016 2:00 PM
  • Hi,

    For me @Ken.s1989's Step 1 & 2 worked. Actually i have following scenario where Client is running Windows 7 and IE 11. And I have developed the .NET based website which is having the Report Viewer control to showcase the reports. and those pages are being opened in an IFrame. It had issue opening page with Blank Report Viewer. But after applying above steps. it worked for me.

    I was scratching my head for part 3 days and this finally seems to be working. 

    Will let you guys know in case other findings.

    Thanks, Parth

    Thursday, April 27, 2017 7:39 AM