locked
Webcam App Not Working.

    Question

  • When I'm using Skype, my webcam works perfectly, but whenever I try the (metro) webcam app that comes built in with Windows 8 nothing happens. What could be wrong?

    Sunday, September 18, 2011 3:12 AM

Answers

  • Hey Godwinium,

     

    Thank you for posting your feedback, we want to make sure we get the right info including your log files.  Can you also submit feedback using the Windows Feedback Tool from the Connect Site associated with your Windows Developer Preview program? If you’re an MSDN subscriber, the information on how to join the Connect program is included on the download page where you installed Windows Developer Preview.  There’s a link to the Connect site and an invitation code that you can click on to join using a Windows Live ID account. If you’re not an MSDN subscriber follow this limited use link to join the Connect program and then follow the steps here


    Steven
    Monday, September 26, 2011 4:30 PM
    Moderator

All replies

  • Make sure the application is allowed to access the camera.

    1- Launch the application

    2- Hit Win + C to get the menu then click "Settings". 

    3- Click on "Control system access for application"

    4- Make sure the webcam setting is on


    T.A. Founder and CEO Apexa www.apexa.co
    Sunday, September 18, 2011 8:34 AM
  • The app has full access to my system I just checked. Also when I launch the camera app, it looks like it's buggy because it keeps flickering and you can't click on the controls in the app bar, they're inactive.
    Sunday, September 18, 2011 4:31 PM
  • Hey Godwinium,

     

    Let's check to see if you see the same problem after refreshing your PC. Here is what will happen you when you refresh your PC:

    • Your files and personalization settings won't change.
    • Your PC settings will be restored to their defaults.
    • Apps from Windows Store will be kept. All other apps will be removed.

     

    Follow the steps below to restore your PC:

    • Enter the Start screen
    • Click Control Panel
    • Click General on the left column
    • Under the Refresh your PC without affecting your files, click Get started

     

    Then follow the instructions that will be displayed on the screen.

     

    After the refresh has completed, test to see if you still encounter the same problem.

     

    Look forward to hearing back from you.


    Steven
    Saturday, September 24, 2011 9:48 PM
    Moderator
  • In fact, I refreshed my PC 2 days ago and the problem is still there. It's not a big deal to me as I rarely use the webcam. Just wanted to alert you guys and let you know of the issue. If it helps, I installed Windows 8 DP on two other machines and the Metro Webcam App works perfectly, It just refuses to work on my newest PC ( A HP Touchsmart 610-1190f), go figure. If you need me to try other things I'm more than willing to help solve this.
    Sunday, September 25, 2011 12:09 AM
  • Hey Godwinium,

     

    Have you tried installing the latest drivers from HP? (Most importantly the video card and webcam drivers)

     

    If not, you can do this by visiting the link below and clicking Drivers and Software. Then find your computer's model and download the latest version of the available drivers. Once the drivers have downloaded, try installing them one by one.

     

    If you encounter a driver that doesn't install properly, try using the compatibility troubleshooter to see if it can install the driver successfully. You can access the compatibility troubleshooter by:

    • Enter the Start screen
    • Type Compatibility
    • Click Settings in the right column
    • Click Run programs made for previous versions of Windows

     

    Then follow the prompts and direct the troubleshooter to the installer for your computer's driver/drivers.


    Steven
    Sunday, September 25, 2011 2:27 AM
    Moderator
  • I have the NVIDIA graphics driver installed but not the Intel HD graphics driver. When I tried installing the Intel HD graphics driver from HP using your suggestions above, it wouldn't install, saying My system does not meet the minimum requirement (this is in compatibility mode). Also the HP high definition webcam driver is installed
    Sunday, September 25, 2011 4:17 AM
  • Hey Godwinium,

     

    Thank you for posting your feedback, we want to make sure we get the right info including your log files.  Can you also submit feedback using the Windows Feedback Tool from the Connect Site associated with your Windows Developer Preview program? If you’re an MSDN subscriber, the information on how to join the Connect program is included on the download page where you installed Windows Developer Preview.  There’s a link to the Connect site and an invitation code that you can click on to join using a Windows Live ID account. If you’re not an MSDN subscriber follow this limited use link to join the Connect program and then follow the steps here


    Steven
    Monday, September 26, 2011 4:30 PM
    Moderator
  • I have submitted a feedback via the Windows Feedback Tool. Hope this helps you guys decipher the problem.
    Tuesday, October 04, 2011 2:26 AM
  • Have you tried running setup wizard in compatibility mode? Help me with installing VIA sound drivers which was pain.
    Well this is the world we live in And these are the hands we're given...
    Tuesday, October 04, 2011 10:21 AM
  • I have iLook 300 webcam from Genius, my dirver is up to date and it works on desctop mode on my Windows8 machine, but in metro style apps it is giving "please connect a camera" message. 

    How can i fix it?

    Thanks

    Monday, January 09, 2012 6:26 PM
  • Hey S_samvel88,

     

    You may need to grant the Metro style application access to your webcam. You can do this by:

    If you have a touch screen:

    • Open the Metro style application
    • Swipe your finger from the right edge of the screen to the center of the screen
    • Touch the Settings charm
    • Touch Control system access for {name of Metro style application}
    • Under Webcam and Microphone, swipe the switch to the On position

     

    If you are using a mouse:

    • Open the Metro style application
    • Move your mouse to the bottom left corner to show the Charms bar
    • Click Settings
    • Click Control system access for {name of Metro style application}
    • Under Webcam and Microphone, click the toggle switch to the On position

     

     

    Hope that helps.


    Steven
    Tuesday, January 10, 2012 12:46 AM
    Moderator
  • Hi

    Thanks for your replay.

    I have already done all that steps, read hundreds posts with the same problem with no success.

    I tried to change my profile picture from control panel(metro style) and was not able to do that as well.

    Wednesday, January 11, 2012 5:56 PM
  • Hey S_samvel88,

     

    Thank you for posting your feedback, we want to make sure we get the right info including your log files. Can you also submit feedback using the Windows Feedback Tool from the Connect Site associated with your Windows Developer Preview program? If you’re an MSDN subscriber, the information on how to join the Connect program is included on the download page where you installed Windows Developer Preview. There’s a link to the Connect site and an invitation code that you can click on to join using a Windows Live ID account. If you’re not an MSDN subscriber follow this limited use link to join the Connect program and then follow the steps here.


    Steven
    Thursday, January 12, 2012 1:31 AM
    Moderator