locked
VS 2017 comments disabled .axml RRS feed

  • Question

  • User217716 posted

    Not sure what happened but today but I cannot comment out code in .axml. .xml files seems to be ok as well c# , html and others. But within an .axml file the comment buttons are disabled. keyboard shortcuts don't work either. ???

    Thursday, August 16, 2018 2:27 AM

Answers

  • User21936 posted

    @GlennErler

    I just tried this and was able to reproduce the issue. I discovered that if you open the same .axml file again with the Automatic Editor Selector (XML), leaving the one opened with the default Android Layout File editor open as well, then the comment/uncomment buttons work as expected. You can even close the Automatic Editor Selector (XML) document one the comment buttons are enabled for your Android Layout File document instance. I.e:

    1. Open your .axml file with the default editor
    2. Right click on the same layout file and select Open With... > Automatic Editor Selector (XML) > OK
    3. Comment buttons should now be enabled for the document in both editors.
    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Wednesday, August 22, 2018 9:07 PM

All replies

  • User21936 posted

    @GlennErler

    I just tried this and was able to reproduce the issue. I discovered that if you open the same .axml file again with the Automatic Editor Selector (XML), leaving the one opened with the default Android Layout File editor open as well, then the comment/uncomment buttons work as expected. You can even close the Automatic Editor Selector (XML) document one the comment buttons are enabled for your Android Layout File document instance. I.e:

    1. Open your .axml file with the default editor
    2. Right click on the same layout file and select Open With... > Automatic Editor Selector (XML) > OK
    3. Comment buttons should now be enabled for the document in both editors.
    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Wednesday, August 22, 2018 9:07 PM
  • User217716 posted

    Thanks for the investigative work!!! Comments are working again.

    Thursday, August 23, 2018 11:34 AM
  • User21936 posted

    Glad to hear it. I filed an internal bug report to address this.

    Thursday, August 23, 2018 7:26 PM