locked
error installing ASDK on HP RRS feed

  • Question

  • no idea where is the problem, I already have 13 hyperV VMs running

    at <ScriptBlock>, <No file>: line 42
    at <ScriptBlock>, <No file>: line 40 - 6/21/2019 9:17:36 AM
    Invoke-EceAction : Type 'Configure' of Role 'NC' raised an exception:
    PowerShell DSC resource DSC.NetworkController  failed to execute Set functionality with error message: Unable to connect to the remote server
    at PublishAndStartDscConfiguration, C:\CloudDeployment\Common\Helpers.psm1: line 1666
    at ConfigureNC, C:\CloudDeployment\Roles\NC\NC.psm1: line 1355
    at Configure, C:\CloudDeployment\Classes\NC\NC.psm1: line 34
    at <ScriptBlock>, <No file>: line 42
    at <ScriptBlock>, <No file>: line 40
    At C:\CloudDeployment\Setup\Common\DeploySingleNodeCommon.ps1:752 char:5
    +     Invoke-EceAction -RolePath $masterRole -ActionType $ActionPlan @d ...
    +     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [Invoke-EceAction], InterfaceInvocationFailedException
        + FullyQualifiedErrorId : ProviderOperationExecutionFailure,CloudEngine.Cmdlets.InvokeCmdlet

    VERBOSE: Step: Status of step '40.49 - (NET) Configure NC on VMs' is 'Error'. - 6/21/2019 9:17:36 AM
    VERBOSE: Checking if any of the in progress steps are complete. The following steps are currently in progress: '40.49'. - 6/21/2019 9:17:36 AM
    VERBOSE: Action: Action plan 'Deployment-Phase1-CreateVMs' failed. Finish running all steps that are currently in progress before exiting. - 6/21/2019
     9:17:36 AM
    VERBOSE: Draining all steps that are still in progress. The following steps are still in progress or just completed: '40.49'. - 6/21/2019 9:17:36 AM
    VERBOSE: Action: Action plan 'Deployment-Phase1-CreateVMs' failed. - 6/21/2019 9:17:36 AM
    Invoke-EceAction : Action: Invocation of step 40.49 failed. Stopping invocation of action plan.
    At C:\CloudDeployment\Setup\Common\DeploySingleNodeCommon.ps1:752 char:5
    +     Invoke-EceAction -RolePath $masterRole -ActionType $ActionPlan @d ...
    +     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [Invoke-EceAction], ActionExecutionException
        + FullyQualifiedErrorId : Unspecified error,CloudEngine.Cmdlets.InvokeCmdlet

    VERBOSE: Action: Status of 'Deployment-Phase1-CreateVMs' is 'Error'. - 6/21/2019 9:17:36 AM
    COMPLETE: Task Cloud - Deployment-Phase1-CreateVMs
    VERBOSE: Task: Status of action 'Deployment-Phase1-CreateVMs' of role 'Cloud' is 'Error'. - 6/21/2019 9:17:36 AM
    VERBOSE: Step: Status of step '40 - Phase 1 - CreateVMs' is 'Error'. - 6/21/2019 9:17:36 AM
    VERBOSE: Checking if any of the in progress steps are complete. The following steps are currently in progress: '40'. - 6/21/2019 9:17:36 AM
    VERBOSE: Action: Action plan 'Deployment' failed. Finish running all steps that are currently in progress before exiting. - 6/21/2019 9:17:36 AM
    VERBOSE: Draining all steps that are still in progress. The following steps are still in progress or just completed: '40'. - 6/21/2019 9:17:36 AM
    VERBOSE: Action: Action plan 'Deployment' failed. - 6/21/2019 9:17:36 AM
    Invoke-EceAction : Action: Invocation of step 40 failed. Stopping invocation of action plan.
    At C:\CloudDeployment\Setup\Common\DeploySingleNodeCommon.ps1:752 char:5
    +     Invoke-EceAction -RolePath $masterRole -ActionType $ActionPlan @d ...
    +     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [Invoke-EceAction], ActionExecutionException
        + FullyQualifiedErrorId : Unspecified error,CloudEngine.Cmdlets.InvokeCmdlet



    PS C:\CloudDeployment\Setup>
    PS C:\CloudDeployment\Setup>
    PS C:\CloudDeployment\Setup>

    Friday, June 21, 2019 9:36 AM

Answers

  • thank you, I managed to find the issue (corrupted asdk-installer.ps1)

    now I have my ASDK fully DISconnected from the internet, capable of nothing

    Wednesday, June 26, 2019 4:25 PM

All replies

  • Are you installing the ASDK in a VM on the HP hardware, or directly on the HP Server?

    Also, please run the Deployment Checker for Azure Stack to make sure that your environment is ready for an ASDK installation. 

    Saturday, June 22, 2019 12:22 AM
  • ASDK on an HP DL380 and precheck says all is ok: I got error twice (I rerun full procedure twice, following the 'cleanup' procedure)

    also tried to run the -rerun option without success

    Monday, June 24, 2019 8:20 AM
  • Is this an AAD or ADFS Deployment? also, can you run the following PowerShell Script while booted into the .VHDX:

    Get-AzureStackLog -OutputPath “<insert file path here>” -FilterByRole seedring,BareMetal

    This will collect deployment logs, and we can look deeper into what happened. Also, can you send me an email at AzCommunity@Microsoft.com with a link to this post, and we can move forward via Email. 

    Tuesday, June 25, 2019 11:17 PM
  • thank you, I managed to find the issue (corrupted asdk-installer.ps1)

    now I have my ASDK fully DISconnected from the internet, capable of nothing

    Wednesday, June 26, 2019 4:25 PM
  • I am guessing that you want your ASDK to be connected, is this correct? If so, do you have the physical machine behind a proxy or other device which might obfuscate the internet connection?
    Thursday, June 27, 2019 11:05 PM