none
Visual Studio 15 preview "4", fail to install -> "failed to load the products definitions",

    Question

  •  

    Hi,

    vs_bootstrapper.exe or vs_installer.exe shows, "failed to load the products definitions";

    I tried to click "retry" many times without any result and my Internet connection is working fine

    Log contains: 
    Error : Failed to get installed product summaries. [installerId: SetupEngine, error: Object reference not set to an instance of an object. at undefined] :-(

    I'm stuck :-(

    Txs for any help

    -Vince


    -Vince

    Monday, September 19, 2016 6:22 AM

All replies

  • Hi Vince,

    Thanks for your post.

    It was confirmed that a known issue in VS15 Preview 4. Please take a look at the release note of Visual Studio "15" Preview 4:

    https://www.visualstudio.com/en-us/news/releasenotes/vs15-relnotes

    In this release note, it has given the workaround to solve this error.

    Error message "Failed to load product definitions." may appear

    • Issue:

         You may experience the following error message when starting the Visual Studio installer application: "Failed to load product definitions."

    • Workaround:

         In most cases, clicking the Refresh button will workaround this issue and successfully load the product definitions.

    Best Regards,

    Lake Xiao



    Tuesday, September 20, 2016 2:27 AM
    Moderator
  • Hi, 

    Txs for your response, but if as I said in my post, I tried to click a huge number of times on "Retry" with the same result.

    I tried to uninstall everything; I tried to use the GitHub VisualStudioUninstaller app from MSFT to remove any VS stuff on my box and then tried to re-install VS 15 preview "4" but still not working.

    As I said, I'm out of solution to fix the issue.

    -Vince



    -Vince

    Tuesday, September 20, 2016 2:49 PM
  • Hi Vince,

    Could you please tell me what's your windows system? 64-bit W10? I have found a lot of people have this issue with 64-bit OS system.

    How about trying the solution in this blog?

    go to C:\Program Files (x86)\Microsoft Visual Studio\Installer, and run vs_installer.exe manually, you will solve the problem

    http://blogs.bukutamudigital.com/2016/07/10/visual-studio-15-new-installer-and-problem-solving/

    In addition, VS15 Preview is not a RTM version of Visual Studio. Why not use Visual Studio 2015 Update3?

    Best Regards,

    Lake Xiao

    Wednesday, September 21, 2016 1:33 AM
    Moderator
  • Hi,

    Yes, I tried.

    Concerning preview "3", too many bugs and new installer doesn't allow me to install the type of apps I'm working actually.

    My goal was to see proof of the claimed speed improvements of VS 15 vs VS 2015 which become more and more slow.

    Cheers

    -Vince


    -Vince

    Wednesday, September 21, 2016 6:53 AM
  • Hi  Vince,

    VS15 Preview is an unsupported pre-release version of Visual Studio. And there have a lot of Known Issues and also exist some unknown issues.

    For your issue, If above workarounds still not apply to your case. Maybe you could consider to log your issue to the Microsoft Connect site.

    http://connect.microsoft.com Microsoft engineers will evaluate them.

    Best Regards,

    Lake Xiao

    Wednesday, September 21, 2016 7:21 AM
    Moderator