locked
Why does Virtual Network assign me different ip from VMs? RRS feed

  • Question

  • I connected my windows 8 machine to virtual network, but ip i got assigned is 10.0.0.8, but my starting IP is specified as 10.0.1.0.

    Friday, August 7, 2015 2:37 AM

Answers

  • That does seem strange... but like the others I'd love to know more about your configuration.

    Is the machine maybe being assigned to the wrong subnet upon creation?  Are you able to use the Preview Portal and change the subnet? 


    Kevin Remde US DX - IT Pro Evangelism - Microsoft Corporation http://aka.ms/FullofIT http://twitter.com/kevinremde


    Monday, August 10, 2015 5:33 PM

All replies

  • Hi,

    Is your Windows 8 machine an Azure VM or an On-Prem machine?
    Also, How are you connecting it to your Virtual Network?

    Regards,
    Malar.

    Friday, August 7, 2015 11:08 AM
  • Greetings!

    Do you see this issue only with the machine running Windows 8.x or with all Azure VMs or on-prem clients associating with that vNet?

    Also, what happens when you release and renew the IP address? Does the machine still acquire an IP address from the DHCP which is out of range from what you've configured?

    It'd be great if you could supplement your above query with screenshots (of the vNet config page on Azure portal and the NIC status page).

     

    Thank you,

    Arvind

    Monday, August 10, 2015 3:06 PM
  • That does seem strange... but like the others I'd love to know more about your configuration.

    Is the machine maybe being assigned to the wrong subnet upon creation?  Are you able to use the Preview Portal and change the subnet? 


    Kevin Remde US DX - IT Pro Evangelism - Microsoft Corporation http://aka.ms/FullofIT http://twitter.com/kevinremde


    Monday, August 10, 2015 5:33 PM
  • Hi,

    Any updates?

    Regards,
    Malar.

    Thursday, August 13, 2015 9:03 AM