none
How to change the culture of the DB2 adapter? RRS feed

  • Question

  • Hi

    When deploying my BTS 06 app onto a staging server, the server is in Europe and the DB2 receive adapter converts decimal points according to the local culture so they arrive from the DB2 adapter as commas instead of dots. Is there a way of changing this, without changing the culture of the staging server? I thought perhaps a setting I could put in btsntsvc.exe.config, or the UDL connection string, or some other config?

    Any ideas appreciated!
    Thursday, July 26, 2007 3:00 PM

Answers

  •  

    Hello Kenton,

    We always use the local culture of the server.

    There is no setting on the adapter that changes this behavior.

    Thanks,

    Ricardo

    Tuesday, October 2, 2007 5:55 PM

All replies

  • Any chance that someone in the BizTalk product team could comment on this please? I'm really trying to engage my client's MS support contract but it's a very slow and arduous process - it's gonna come your way anyway Wink

     

    I consider this a bug in the product: if decimal data is read from DB2, and schema validation is performed in the pipeline on this decimal field, it will fail. I don't have a workaround for this - right now I've had to turn off validation; furthermore, I've now got the problem going back the other way whereby eg 54.0000 in my updategram is interpreted as 540000 because the dot is interpreted as the thousands separator.

     

    I hope someone can help - thanks!

    Tuesday, August 7, 2007 2:40 PM
  •  

    Hello Kenton,

    We always use the local culture of the server.

    There is no setting on the adapter that changes this behavior.

    Thanks,

    Ricardo

    Tuesday, October 2, 2007 5:55 PM
  • Hi,

    I am experiencing the same problem: on my test sever the Biztalk DB2 adapter has different behaviour than in production. Originally there where differences in the regional settings between the two machines. I now set them the same but the problem still persists, even after a reboot.

    I have made sure that everything under "Control Panel" -> "Regional and Language options" is the same. Is the local culture a setting I have to change somewhere else? Or do I need to reinstall the DB2 adapter after changing it?

    Any help would be really appreciated.

    Kind regards,

    Peter.
    Thursday, January 8, 2009 10:43 AM
  • Just to come back on my own question: actually it is sufficient to just change the locale and then restart the Biztalk service. The problem in my case was that I changed the locale for the user logged on to the machine but not the locale for the user that was running the Biztalk service. Once I changed the locale for that user all worked fine.
    Monday, January 12, 2009 10:28 AM