locked
Can't select Xbox on the packages page RRS feed

  • Question

  • Hi everyone,

    I'm trying to port my Construct 2 game to UWP so I can release it on the Xbox One Creators Program, but after uploading the package the review shows the package as "incomplete".

    I've searched around and found a thread (https://social.msdn.microsoft.com/Forums/windowsapps/en-US/52e32c63-d2c2-434b-9dae-365a973c4c41/uwpxbox-no-compatible-packages-for-xbox?forum=wpdevelop)  which seems to be exactly my problem, but I'm not sure I'm using any dependencies that are unsupported, or how to remove them.

    On the appmanifest file, "Internet(Client)" is selected but I've also tried turning it off and building the package, it still showed as incomplete.

    Thanks,

    Andre Silva

    Saturday, August 12, 2017 9:31 PM

All replies

  • Does your package include binaries for the x64 architecture? UWP on Xbox can only run x64, not x86 or ARM.

    Have you actually *run* your game on UWP on Xbox (via retail unlock or on a dev kit)?

    Did you run WACK on your UWP while running on the Desktop? Did you get any errors/warnings?


    Saturday, August 12, 2017 11:51 PM
  • Hi Chuck,

    Sorry about the lack of details! Yes, I tried both Neutral and x64 options. I can install the app package on the Xbox One just fine if I go to devhome and enter the IP address on my PC's browser, then send it to the Xbox. 

    I did run WACK and it says everything is fine, no errors whatsoever. 

    After I upload the app package to the submission, it works as intended if I do not check the Xbox box. Like the other thread I mentioned, this is what shows up at that page:

    http://i.imgur.com/1xZT1vR.png

    And if I go to packages:

    http://i.imgur.com/kvWU0d0.png

    Edit: Maybe I'm missing something so here are the steps I take:

    1. Export the game from Construct 2 to UWP

    2. Open the solution file

    3. Go to Project -> Store -> Edit App Manifest

    4. Add images to the Visual Assets tab

    5. Go to Project -> Store -> Create App Package

    6. Pick existing app name that I've already set up

    7. Use Neutral - Release (AnyCPU) config - generate appbundle is set to "always"

    8. After the package is created, it asks me if I want to run WACK, I accept

    9. After WACK is done, open the report, everything is OK, no errors or warnings anywhere

    10. Go to my games folder\AppPackages\AnyCPU_bundle.appxupload and upload it to the submission

    After it's done uploading, there's nothing under the "Windows 10 Xbox" checkbox. If I try turning all options off but the Xbox one, it says my submission is incomplete.

    • Edited by AndreYin Sunday, August 13, 2017 12:42 AM adding more info
    Sunday, August 13, 2017 12:12 AM
  • Just an update - I'm completely stumped. I've contacted the developer of GalactiMAX, which is also a Construct 2 game, and he said it seems I'm doing nothing wrong.

    So far I've tried:

    - a completely new, empty project with nothing but the xbox live plugin (with the right info on it).

    - using a template from C2 and adding the xbox live plugin to it.

    - exporting as a appxupload instead of a bundle (since the bundle one was always showing as "Neutral" and according to a guide the developer of C2 wrote, we should be creating the app packages as x64 only.

    Of course, none of these worked and still when I upload my appx to my submission, I cannot select "Windows 10 Xbox".

    We talked a bit and one of the conclusions we could come up with is that since I was already ID@Xbox approved, maybe I'm not being able to use the Creators Program. I've contacted one of the emails for it and I'm awaiting a response.

    I've also tried to make another dev account for testing purposes, but the creators program doesn't show there and I'm not sure how to enable it.


    • Edited by AndreYin Monday, August 14, 2017 3:26 PM
    Monday, August 14, 2017 3:24 PM
  • Another update - I finally got it to work.

    Thanks to a fellow C2 user who told me to go to the project properties and use 10.0.14393.0 on the Target version. I tried using 10.0.10240.0 which was the default, and 10.0.10586.0 which is the highest value, but none of these worked - only 10.0.14393.0.


    • Edited by AndreYin Monday, August 14, 2017 5:41 PM
    • Proposed as answer by Mattew Wu Tuesday, August 15, 2017 2:04 AM
    Monday, August 14, 2017 5:39 PM
  • Hi AndreYin,

    You might check the documentation Device family availability:

    " if you check Windows 10 Xbox, your highest-versioned package that’s applicable to Xbox (that is, a neutral or x64 package that targets the Xbox or Universal device family) will always be offered to customers on Xbox, even if it is compiled with an earlier SDK version. Because of this, it’s critical to ensure that the highest-versioned package applicable to Xbox is compiled with Windows SDK version 14393 or higher. If it is not, you will see an error message indicating that Xbox customers will not be able to launch your app."  

    Glad to hear that you have made it work. You might as well mark that response as answer so that other community member faced with same problem can find it more conveniently.

    Thanks for your understanding.

    Best regards,

    Mattew Wu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    • Edited by Mattew Wu Tuesday, August 15, 2017 2:05 AM
    • Proposed as answer by ECHS BACHS Sunday, September 3, 2017 10:10 AM
    Tuesday, August 15, 2017 2:04 AM
  • Thanks for this Post Thread, it helped Me.

      :  )


    http://games.archor.com

    Sunday, September 3, 2017 10:08 AM