none
Service Bus 1.0 cumulative update RRS feed

  • Question

  • Hello,

    in order to install the 26/02/2013 version of the Microsoft Office Developer Tools for Visual Studio 2012, you need to install first the Service Bus 1.0 Cumulative Update 1.

    The thing is that I can not install this update, I always get an error:

    DownloadManager Information: 0 : Using cached file at C:\Users\Gilles\AppData\Local\Microsoft\Web Platform Installer\installers\ServiceBusCU1\5024FF633CA537CDB1C2903F97E1244457BAEE18\ServiceBus-KB2799752-x64-EN.exe instead of downloading from http://go.microsoft.com/fwlink/?LinkId=285191&CLCID=0x409
    DownloadManager Information: 0 : Starting EXE command for product 'Service Bus 1.0 Cumulative Update 1'. Commandline is: 'C:\Users\Gilles\AppData\Local\Microsoft\Web Platform Installer\installers\ServiceBusCU1\5024FF633CA537CDB1C2903F97E1244457BAEE18\ServiceBus-KB2799752-x64-EN.exe /quiet'. Process Id: 6308
    DownloadManager Information: 0 : Install exit code for product 'Service Bus 1.0 Cumulative Update 1' is '-1'
    DownloadManager Error: 0 : Install return code for product 'Service Bus 1.0 Cumulative Update 1' is Failure
    DownloadManager Information: 0 : Product Service Bus 1.0 Cumulative Update 1 done install completed
    DownloadManager Information: 0 : Increasing current install to 2

    if I run C:\Users\Gilles\AppData\Local\Microsoft\Web Platform Installer\installers\ServiceBusCU1\5024FF633CA537CDB1C2903F97E1244457BAEE18\ServiceBus-KB2799752-x64-EN.exe

    I get : "an unexpected internal error has occured."

    I am running Windows 8.

    Somebody having the same issue?

    Thx

    Gilles


    http://gilleslauwers.wordpress.com

    Friday, March 8, 2013 1:49 PM

All replies

  • Gilles, could you please find the setup.log file and paste the content here? It's usually under "C:\ProgramData\Microsoft\E-Business Servers Updates\Updates\Uninstall2799752". That would help us better diagnose what's wrong with your installation.

    Thanks,

    SGuy

    Friday, March 8, 2013 6:02 PM
  • Hello,

    I do not have any folder called E-Business Server Updates.


    http://gilleslauwers.wordpress.com

    Tuesday, March 12, 2013 9:59 AM
  • According to the error "an unexpected internal error has occured" and the fact that the folder doesn't exist, it's likely the file ServiceBus-KB2799752-x64-EN.exe is corrupted and thus didn't install at all.

    Instead of installing from WebPI, please try to download the Service Bus CU here (http://www.microsoft.com/en-us/download/details.aspx?id=36794), install it and see how it goes.

    Thanks,

    SGuy

    Tuesday, March 12, 2013 10:55 PM
  • I just did that and I got this:

    an unexpected internal error has occured.

    and still no sign of the folder C:\ProgramData\Microsoft\E-Business Servers Updates\Updates\Uninstall2799752


    http://gilleslauwers.wordpress.com

    Wednesday, March 13, 2013 8:42 AM
  • The error message "an unexpected internal error has occured" doesn't tell us much regarding what's wrong there, but one thing for sure is the actual installation didn't even start because of this error.

    I suppose you got this error from a message box, what's the title of the message box?

    Wednesday, March 13, 2013 10:42 PM
  • the title of the message box is Setup.exe


    http://gilleslauwers.wordpress.com

    Thursday, March 14, 2013 6:15 PM
  • Could you download the CU for Workflow Manager (http://www.microsoft.com/en-us/download/details.aspx?id=36800), try to install it and see if you'll get the same "unexpected internal error" or something else?
    Thursday, March 14, 2013 8:32 PM
  • Thursday, March 14, 2013 8:35 PM
  • Are you running as admininstrator when installing? I suppose so but want to confirm.
    Thursday, March 14, 2013 9:03 PM
  • Yes of course, any idea how could i get more logs on that?

    http://gilleslauwers.wordpress.com

    Thursday, March 14, 2013 9:36 PM
  • OK, please try to run the following command line, and see if there will be anything in the resulting SBCUInstallation.log file.

    > ServiceBus-KB2799752-x64-EN.exe /log SBCUInstallation.log

    Thursday, March 14, 2013 10:08 PM
  • the log file is not even generated :(

    http://gilleslauwers.wordpress.com

    Friday, March 15, 2013 12:56 PM
  • Maybe you can try this and see if it helps. Use a zip tool like WinZip or 7Zip to extract ServiceBus-KB2799752-x64-EN.exe to a folder (make sure the folder path isn't too long, e.g. C:\Temp\SBCU), and then run the setup.exe from the extracted folder.

    Wednesday, March 20, 2013 5:27 PM
  • I tried it already, didn't work

    I tried to execute the msp file directly, it runs for some seconds then ends without giving me any message but web plateform installer still does not see it as installed


    http://gilleslauwers.wordpress.com

    Thursday, March 21, 2013 9:14 AM
  • Directly installing the MSP won't work, you must install with setup.exe.

    Have you tried to run ServiceBus-KB2799752-x64-EN.exe on other machines? I know other machines might not have Service Bus installed, but you can still run it and see what error you'll get. Does the "unexpected error" happen only on this machine only or on all machines?

    With current information it's quite impossible to figure out what's wrong there. If you can provide us with a repro (e.g. take a snapshot of your hard disk with disk2vhd so that we can use it to repro the issue), we can further investigate, otherwise I'm afraid there's nothing more we can do.

    Thursday, March 21, 2013 4:46 PM
  • I have no problem on other machine, it is just on mine :)

    thx for your help anyway.


    http://gilleslauwers.wordpress.com

    Thursday, March 21, 2013 5:47 PM
  • When you install the workflow manager tools for visual studio , it requires certain prerequisite for a successful installation. If you don't follow the order of installation , then installation will not get completed successfully.
    Follow the steps
    1. Download and Install Workflow Manager Client 1.0  or Workflow Manager (Use workflow Manager installer If you want to have developer box loaded with everything on a single box)

    Microsoft Office Developer Tools for Visual Studio 2012, needs Cumulative Update so you need to install the folowing cumilative updates first.

    2.. Download and Install Cumulative update for Service Bus 1.0
    You need to install service bus update first in order to complete the workflow manager cumulative update successfully.

    Now you could install the workflow manager tools

    Tuesday, April 16, 2013 11:26 PM
  • i have same problem, did you find the issue?
    Wednesday, June 5, 2013 12:10 AM
  • Not yet. Is it possible for you to provide us with a repro (e.g. take a snapshot of your hard disk with disk2vhd so that we can use it to repro the issue)? If so we can further investigate.
    Wednesday, June 5, 2013 12:20 AM
  • This requires a 64-bit environment, correct?  I'm getting this same issue, under Windows Pro 8 (32-bit version).

    Christopher Reed

    "The oxen are slow, but the earth is patient."


    • Edited by CA Reed Thursday, June 13, 2013 10:56 PM
    Thursday, June 13, 2013 10:55 PM
  • I'm having the same issue... any news?
    Sunday, July 7, 2013 9:48 PM
  • Unfortunately the answer is no as we cannot repro the issue in house. If you are willing to send us a VHD file for investigation, that would help both yourself and other users running into the same issue. Send me an email if you decide so and I'll follow up with you. My email is SGuy Ge at microsoft dot com, remove any spaces in between.
    Monday, July 8, 2013 10:58 PM
  • I am pretty sure that Gilles tries to install it on a Windows 7 machine. I am running into the same problem and I am not able to use the visual studio workflow manager tools even if I try to use the workflow manager client only.

    I was able to generate log files (below):

    But can you please tell me how to maintain a developer host if even the simple task of updating the product dosen't work?!?

    WF (german):

    [08/07/13 20:29:23] Installation wird ausgeführt.
    [08/07/13 20:29:23] Mindestens eines der Produktpakete wurde gefunden.
    [08/07/13 20:29:23] preReqUpdateDisplayName is :
    [08/07/13 20:29:23]
    [08/07/13 20:29:23] preReqUpdateDisplayName is :
    [08/07/13 20:29:23]
    [08/07/13 20:29:23] Assistent-Modus eingeschaltet.
    Die folgenden Produkte werden optimiert:
    Workflow Manager Client 1.0
    Attempting to open cached Msi package for product code: {7E04AA1F-E2E3-427F-B679-9E2592CBC3C1}
    Successfully opened cached Msi package.
    Workflow Manager 1.0
    Attempting to open cached Msi package for product code: {04A7199E-565D-4654-88A3-80A9A7BADDD9}
    Successfully opened cached Msi package.
    [08/07/13 20:29:28] Dienststeuerungs-Manager wird geöffnet...
    [08/07/13 20:29:28] Vorgang erfolgreich abgeschlossen.
    [08/07/13 20:29:28] Dateien werden kopiert...
    [08/07/13 20:29:28] Das Zielverzeichnis \Microsoft\E-Business Servers Updates\Updates\Uninstall2799754 wird geprüft und erstellt.
    [08/07/13 20:29:28] Das Verzeichnis \Microsoft\E-Business Servers Updates\Updates\Uninstall2799754 ist nicht vorhanden.
    [08/07/13 20:29:28] Das Verzeichnis  ist nicht vorhanden.
    [08/07/13 20:29:28] Das Verzeichnis  wird erstellt ...
    [08/07/13 20:29:28] Vorgang fehlgeschlagen.
    [08/07/13 20:29:28] Das Paket  Workflow Manager Client 1.0 wurde installiert.
    [08/07/13 20:29:28] Datei AppServerV1-WorkflowManagerClientx64patch30.msp wird kopiert ...
    [08/07/13 20:29:28] Fehler beim Kopieren der Datei AppServerV1-WorkflowManagerClientx64patch30.msp
    [08/07/13 20:29:32] Fehler beim Kopieren der Datei AppServerV1-WorkflowManagerClientx64patch30.msp
    [08/07/13 20:29:32] Vorgang fehlgeschlagen. Fehlercode lautet 3.

    SB (german too):

    [08/07/13 20:34:07] Installation wird ausgeführt.
    [08/07/13 20:34:07] Mindestens eines der Produktpakete wurde gefunden.
    [08/07/13 20:34:07] preReqUpdateDisplayName is :
    [08/07/13 20:34:07]
    [08/07/13 20:34:07] Assistent-Modus eingeschaltet.
    Die folgenden Produkte werden optimiert:
    Service Bus 1.0
    Attempting to open cached Msi package for product code: {F438C511-5A64-433E-97EC-5E5343DA670A}
    Successfully opened cached Msi package.
    [08/07/13 20:34:13] Dienststeuerungs-Manager wird geöffnet...
    [08/07/13 20:34:13] Vorgang erfolgreich abgeschlossen.
    [08/07/13 20:34:13] Dienst Service Bus Gateway wird geöffnet...
    [08/07/13 20:34:13] Vorgang erfolgreich abgeschlossen.
    [08/07/13 20:34:13] Dienst Service Bus Message Broker wird geöffnet...
    [08/07/13 20:34:13] Vorgang erfolgreich abgeschlossen.
    [08/07/13 20:34:13] Dateien werden kopiert...
    [08/07/13 20:34:13] Das Zielverzeichnis \Microsoft\E-Business Servers Updates\Updates\Uninstall2799752 wird geprüft und erstellt.
    [08/07/13 20:34:13] Das Verzeichnis \Microsoft\E-Business Servers Updates\Updates\Uninstall2799752 ist nicht vorhanden.
    [08/07/13 20:34:13] Das Verzeichnis  ist nicht vorhanden.
    [08/07/13 20:34:13] Das Verzeichnis  wird erstellt ...
    [08/07/13 20:34:13] Vorgang fehlgeschlagen.
    [08/07/13 20:34:13] Das Paket  Service Bus 1.0 wurde installiert.
    [08/07/13 20:34:13] Datei AppServerV1-ServiceBuspatch30.msp wird kopiert ...
    [08/07/13 20:34:13] Fehler beim Kopieren der Datei AppServerV1-ServiceBuspatch30.msp
    [08/07/13 20:34:16] Vorgang fehlgeschlagen. Fehlercode lautet 3.

    Thursday, August 8, 2013 9:19 AM
  • SOLVED:

    What a hack... I am able to use the visual studio workflow manager tools with the cu1 for service bus and workflow manager too.

    1. use the downloads not the web platform installer
    2. unzip the exe with 7z
    3. create a dir with full rights: "c:\microsoft\e-business server updates"
    4. modify the setup.xml: FolderName=""
    5. run: setup /log install.log
    6. ignore the html error message
    7. wait !
    8. installation done
    9. sb only: restart the machine
    10. check the result: programs and functions -> installed updates
    Thursday, August 8, 2013 10:50 AM
  • Hello Freddy,

    I have in fact the issue on Windows 8 but I am going to try right away your solution.


    http://gilleslauwers.wordpress.com

    Thursday, August 8, 2013 10:55 AM
  • Thursday, August 8, 2013 11:01 AM
  • I do have the same error, but It happened after I had to reinstall the service bus. Now, If i try to run the setup of the cumulative update I got the following error.


    Luis Diego Rojas. http://icomparable.blogspot.com


    MCP, MCTS Biztalk Server, MCTS WCF

    Sunday, August 18, 2013 3:54 AM
  • I just tried the solution proposed (expand the .exe, edit setup.xml, create a folder with full control) in my Windows 8, and it works!

    Thanks!

    (I applied the same to other thing the Visual Studio Tools for Office 2012 reject: cumulative update of workflow manager or something alike. I read the log, locate the .exe fail that complains, expand the .exe, edit setup.xml putting FolderName="", etc...)

    Friday, December 27, 2013 4:00 PM