none
Tracker - Failed to execute command. 64 bit version of Windows 7 RRS feed

  • Question

  • Hi,

    My level of sophistication is a little lower than what I have been reading. Can someone give me the cliff notes solution to this problem?

    My application has been running in VB 2005 on 32 bit systems. I have recently bought 3 systems that are windows 7, Home Premium and Professional, 64 bit OS. When I bring my VB2005 code into VS2010 it will run but It will not compile with new changes. When I run code that was created in VS2010 on a 32 bit system I get the same error. Thus I cannot make any changes to my code and have now hit a brick wall in terms of my investment and business. My good friend who is a much stronger programmer has not tried a 64 bit computer yet. I have to pay him for help. after several hours he has not been able to solve the problem. Another friend (also stronger programmer than I) has not seen the problem. I am having this problem on all three computers in my shop that are 64 bit. One of these machines is due to a customer in the next few weeks.

    We have tried the suggestions listed here

    I was unable to put the link (submit button complained) here is the title "Tracker/Resgen failure in VS2010 when targetting 3.5 framework" in some visual studio forum

    All machines are up to date with Windows Updates.

    I am still using 2.0 .Net Framwork

    Here is the error message I recieve. I have two projects in my solution and I get 1 error per project.  Both error messages have the same structure (Failed to execute ... The handle is invalid - Tracker):

    Error 4 Failed to execute command: ""C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\Bin\ResGen.exe" /useSourcePath /r:C:\Windows\Microsoft.NET\Framework\v2.0.50727\System.Data.dll /r:C:\Windows\Microsoft.NET\Framework\v2.0.50727\System.dll /r:C:\Windows\Microsoft.NET\Framework\v2.0.50727\System.Drawing.dll /r:C:\Windows\Microsoft.NET\Framework\v2.0.50727\System.Windows.Forms.dll /compile "My Project\Resources.resx,obj\Debug\JDS_Tools.Resources.resources" ucImages.resx,obj\Debug\JDS_Tools.ucImages.resources ucMessageQueue.resx,obj\Debug\JDS_Tools.ucMessageQueue.resources". The handle is invalid. C:\Users\JDS 2\Documents\JDS Consulting\Projects\Tool and Assembily Systems\1142 Teleprompter\VB\Teleprompter - 4.0.0 - Copy\JDS_Tools\TRACKER JDS_Tools

    Please help!

    Jeff

    • Moved by Ego Jiang Monday, December 31, 2012 2:59 AM (From:Visual Studio Setup and Installation)
    • Moved by Mike FengModerator Thursday, January 3, 2013 2:52 AM restructure .NET forums (From:Building Development and Diagnostic Tools for .Net)
    Saturday, December 29, 2012 9:08 PM

Answers

  • OK, problem now seems to be solved (by friend Gary) (time will tell). Solution was to target the 4.0 frame work on the 32 bit system (was running 2.0 frame work) for all projects in my solution.  Save then close the solution. (VS2010 gave a message to do that) Then re-open the solution and compile on the 32 bit system. I received no errors and it runs. I then took the source code to my 64 bit system opened and compiled. It ran without errors. I then made a change to the code and it still complied and ran.  I have tested this on three of the 4 Win 7, 64 bit machines I have here.  No more “Failed to execute…FU” error!

    I did come across another thing that I found strange.  A dll was proved by my customer for interfacing to their production server.    This dll was created a few years back.  Two of the Win 7, 64 bit machines I tested this on has Home Premium.  The other machine is Win7, Professional.  The application runs without error on the Home Premium machines put will not run on the Professional machine.  Program execution stops when calling an initialization function in the dll and then crashes hard.

    AAAAAhhhhh, the wonders of keeping up with the ever changing OS.  Happy coding my friends!

    Jeff

    • Marked as answer by JDS Test Friday, January 4, 2013 1:11 AM
    Friday, January 4, 2013 1:09 AM

All replies

  • Hi Jeff,

    Based this issue related to ResGen.exe, I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.
     
    Thank you for your understanding and support.

    Best regards, 


    Ego [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, December 31, 2012 2:58 AM
  • How about this thread: http://social.msdn.microsoft.com/Forums/zh/msbuild/thread/58386669-c50a-4966-8ab5-b1abe6321476 

    Ghost,
    Call me ghost for short, Thanks
    To get the better answer, it should be a better question.

    • Marked as answer by Mike FengModerator Wednesday, January 2, 2013 3:28 AM
    • Unmarked as answer by JDS Test Wednesday, January 2, 2013 5:52 PM
    Monday, December 31, 2012 9:40 AM
  • Is there anything else? <o:p></o:p>

    I read through the link (same link twice) provided above. The Jeff in that thread does not
    seem to have received a valid answer. Also when I try to go to any of the links
    in that thread they do not exist expect for this one http://social.msdn.microsoft.com/Forums/en/msbuild/thread/e5900710-9849-4d10-aa28-48b734d06bf2<o:p></o:p>

    I have already tried the suggestions listed in that thread and I still have the
    problem. <o:p></o:p>

    Jeff :-(<o:p></o:p>


    Wednesday, January 2, 2013 5:35 PM
  • Really looking for some help here! 

    My shell program complies and runs just fine in VS2010 on Win7 Professional, SP1, 32 bit.  I take the same solution to my Win7 Home Premium, SP1, 64 Bit VS2010 and the get the error mentioned above (Error 4 Failed to execute command...).  I get the same error when I take the solution to a second system I have with Win 7, Pro, SP1, 64 bit.  Per the threads suggested and what we can find by searching we have tried the following:

    1) Delete all resx files in the solution

    2) tried option 2:

    Option 1.     Try using the 64-bit version of tracker.exe, even for 32-bit builds, when targeting .NET 3.5 and lower.  Indicate you want to run ResGen as a tool, and that it is ManagedIL (Managed32Bit doesn't work because of this flagging issue):

    a.    Add this to your MSBUILD command-line:
    /p:ResGenExecuteAsTool=true;ResGenToolArchitecture=ManagedIL;ResGenTrackerSdkPath=”%programfiles(x86)%\Microsoft SDKs\Windows\v7.0A\bin\NETFX 4.0 Tools\x64”

    b.    Or add this to your project:
    <PropertyGroup Condition="'$(TargetingClr2Framework)' == 'true'">
      <ResGenExecuteAsTool>true</ResGenExecuteAsTool>
      <ResGenToolArchitecture>ManagedIL</ResGenToolArchitecture>
      <ResGenTrackerSdkPath>$(SDK40ToolsPath)\x64</ResGenTrackerSdkPath>
    < /PropertyGroup>

    Option 2.    Set the 32-bit flag on resgen.exe

    a.    Open a Visual Studio command-prompt as an administrator

    b.    Navigate to the Microsoft SDKs\Windows\v7.0A\bin directory.

    c.    ***SAVE A COPY*** of your original resgen.exe file.  This is very important if you want to be able to replace our tweak with the original file without having to repair your installation.
    copy resgen.exe regen.exe.old

    d.    Set the 32-bit flag to true using corflags.exe
    corflags.exe resgen.exe /32BIT+ /Force

    3) tried copying the ResGen.exe file from my 32 bit system to my 64 bit system per this persons suggestion

    Wednesday, November 09, 2011 5:14 PM
    Avatar of ShenAtMCC
    ShenAtMCC
    Avatar of ShenAtMCC

    ShenAtMCC

    Medical Council of Canada

    5 Points200
    Recent Achievements
    First Forums ReplyNew Blog Commentator
    Medical Council of Canada
    5 Points
                    
                     Proposed Answer
    Vote As Helpful

    It seems that resgen.exe installed by some version of VS2010 may be corrupted. My solution is to copy the resgen.exe from a machine that does not have this resgen issue to C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\Bin. And problem is gone. corflags indidates that 32bit flag is not set in resgen.exe which works.

    4) tried to change the target to 4.0 frame work and still get same error when I complie.

    Mr. Ghost.  I do not know what other detail to provide you.  Please provide more detail as to what I need to provide you in order to get some meaningful help here. I am having a hard time understanding your answer when I do not understand what is being said and some of the links that are within that thread no longer exists.  Am I to assume that Microsoft does not care about there customers.  If I treated my customers the way that I feel that I am being treated here I would be out of business...and may soon be

    Jeff :-(  :-(  :-(



    • Edited by JDS Test Thursday, January 3, 2013 2:12 AM
    Thursday, January 3, 2013 1:24 AM
  • OK, problem now seems to be solved (by friend Gary) (time will tell). Solution was to target the 4.0 frame work on the 32 bit system (was running 2.0 frame work) for all projects in my solution.  Save then close the solution. (VS2010 gave a message to do that) Then re-open the solution and compile on the 32 bit system. I received no errors and it runs. I then took the source code to my 64 bit system opened and compiled. It ran without errors. I then made a change to the code and it still complied and ran.  I have tested this on three of the 4 Win 7, 64 bit machines I have here.  No more “Failed to execute…FU” error!

    I did come across another thing that I found strange.  A dll was proved by my customer for interfacing to their production server.    This dll was created a few years back.  Two of the Win 7, 64 bit machines I tested this on has Home Premium.  The other machine is Win7, Professional.  The application runs without error on the Home Premium machines put will not run on the Professional machine.  Program execution stops when calling an initialization function in the dll and then crashes hard.

    AAAAAhhhhh, the wonders of keeping up with the ever changing OS.  Happy coding my friends!

    Jeff

    • Marked as answer by JDS Test Friday, January 4, 2013 1:11 AM
    Friday, January 4, 2013 1:09 AM
  • So exciting.

    Ghost,
    Call me ghost for short, Thanks
    To get the better answer, it should be a better question.

    Friday, January 4, 2013 1:15 AM