locked
Comment/Uncomment does not work in VS2013 RRS feed

  • Question

  • I saw a thread that this was an issue in VS2012 also.

    When I select a block of code and click the comment button in the tool bar nothing happens. same for uncomment. The shortcut also does not work. Is tere a toggle to turn this on and off? If i manualy type in a ' in front of the line it works and changes to green comment.

    Wednesday, May 14, 2014 12:50 PM

Answers

  • Thanks for TejasJ’s help.

    Hi lrjanzen,

    I also test it in my side with VS2013, it worked well.

    If you use the menu options "comment and uncomment" under EDIT->Advanced like the following screen shot, does it work well for the selected code?

    We also need to check whether it is the specific project issue, maybe you could create a simple C# console app, check it again.

    If still has this issue, I doubt that it is your VS Environment issue.

    Please reset VS settings, and recreate a new project, check it again.

    http://msdn.microsoft.com/en-us/library/ms247075(v=vs.100).aspx

    Please install the VS2013 update 2.

    If still no help, I suggest you remove all add-ins in your VS IDE, and then repair your VS.

    Best Regard,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, May 15, 2014 6:57 AM

All replies

  • I am able to comment and uncomment code by clicking 'Comment out the selected lines' and 'Uncomment the selected lines' buttons in Text Editor toolbar as well as by keyboard shortcuts: Ctrl + K, C or Ctrl + E, C and Ctrl K, U or Ctrl E, U respectively in a VB project in VS2013.

    TejasJ.

    Wednesday, May 14, 2014 1:22 PM
  • Thanks for TejasJ’s help.

    Hi lrjanzen,

    I also test it in my side with VS2013, it worked well.

    If you use the menu options "comment and uncomment" under EDIT->Advanced like the following screen shot, does it work well for the selected code?

    We also need to check whether it is the specific project issue, maybe you could create a simple C# console app, check it again.

    If still has this issue, I doubt that it is your VS Environment issue.

    Please reset VS settings, and recreate a new project, check it again.

    http://msdn.microsoft.com/en-us/library/ms247075(v=vs.100).aspx

    Please install the VS2013 update 2.

    If still no help, I suggest you remove all add-ins in your VS IDE, and then repair your VS.

    Best Regard,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, May 15, 2014 6:57 AM