none
Windows 2010. Problem with publishing.

    Question

  • Hi there

    I migrated to Windows 2010/VS2015/IIS10. Having that finished, I cannot publish the Website to a mapped drive.

    To start my Web project in Visual Studio, I was recommended to start it as Administrator (otherwise, it does not debug on IIS).

    If started as Administrator, Visual Studio cannot publish to a mapped drive, let's say Y until I close the Studio and open it in the regular way (as not an Administrator). How to avoid this switching Administrator-Not Administrator for publishing? Which security setting must be changed?

    Maybe it is possible to avoid the Administrator launch and always start the Studio as a PC user enjoying the debugger with no problem?

    Thanks.

    Wednesday, October 5, 2016 1:29 PM

Answers

  • Hi Renziglov,

    According to the error message, 500 internal Server Error means it comes from the server side. And this issue fixed when your launch VS as administrator.

    I think this issue should be related to your current Windows User's permissions. Please check current Windows User has added into administrator group and it has all read/write permission to do any operations.

    And you also can switch the Windows user as administrator and then use the Administrator to login your windows and debug your web server.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, October 10, 2016 6:59 AM
    Moderator

All replies

  • Hi Renziglov,

    Does the Windows 2010 means Windows 10?

    According to your description, I try debug and publish my web application through Visual Studio 2015 on my Windows 10 machine. No matter I debug/publish my web project as Administrator or doesn't as Administrator, it could be debug on IIS and publish successful.

    So I don't think there has any permission switch on Visual Studio to control it debug and publish in different permissions.

    I suggest you check the mapped drive permission, whether there has different permissions for administrator and current Windows user.

    In addition, what error message do you get if you debug your web project without administrator and publish your web project with administrator. It can help us check whether there has any usable information in error message.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, October 6, 2016 6:10 AM
    Moderator
  • >Does the Windows 2010 means Windows 10?

    Oh, yes. Certainly.

    When I launch it as a non-administrator, I get:

    Unable to start debugging on the Web server.
    IIS does not list a web site that matches the launched URL

    When I start publish to a mapped drive, I get:

    1>Connecting to Y:\Project...
    1>Unable to create the Web site 'Y:\Project'.  The path 'Y:\Project' does not exist or you do not have access. The system cannot find the path specified.

    Thanks.

    Thursday, October 6, 2016 4:50 PM
  • Hi Renziglov,

    For the debug issue, please check our IIS settings, make sure it has enable Windows Authentication. And then turn on the 'IIS Metabase and IIS 6 configuration compatibility' through below steps.

    1. Click Start, and then click Control Panel.
    2. Click Programs.
    3. Click Turn Windows features on or off.
    4. In the User Account Control dialog box, click Continue.
    5. Expand Internet Information Services, expand Web Management Tools, and then expand IIS 6 Management Compatibility.
    6. Click to select the IIS Metabase and IIS 6 configuration compatibility check box, and then click OK.

    For the publish issue, according to the error message, it should be caused by the permission issue to the path that you assigned. I suggest you check the permisssions of administrator to this path to make sure it has all read/write permission. And you also need to confirm this path is exsiting.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, October 7, 2016 1:21 AM
    Moderator
  • Hi there

    I modified the Windows Authentication. Now it is enabled. The second part (IIS Metabase) found to be the same as you described. No modification made to it. Now I get the different message:

    Unable to start debugging on the web server.
    The remote server returned an error: (500) Internal Server Error.

    And if I launch the VS as an Administrator, I can debug Ok.

    Any clue?

    Thanks.

    Friday, October 7, 2016 6:50 PM
  • Hi Renziglov,

    According to the error message, 500 internal Server Error means it comes from the server side. And this issue fixed when your launch VS as administrator.

    I think this issue should be related to your current Windows User's permissions. Please check current Windows User has added into administrator group and it has all read/write permission to do any operations.

    And you also can switch the Windows user as administrator and then use the Administrator to login your windows and debug your web server.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, October 10, 2016 6:59 AM
    Moderator