none
[E2010][EWSMA][C#][Windows]: EWS delegate operations affecting settings of delegate security groups RRS feed

  • Question

  • We currently add a security group as a delegate to users' mailboxes that is enabled to receive schedulers then add or remove users to the group as necessary. I'm writing an application to manage delegates remotely using the EWSMA, however it appears that adding/updating or removing delegates using the API disables the option to receive schedulers for the security groups.

    Before: HBuckleCalendar & Schedulers are security groups

    After adding a delegate using EWSMA the option to receive schedulers for the group is cleared:

    These are the request and response from the server, there's no mention of the group in there so not sure why they are being affected.

    <Trace Tag="EwsRequest" Tid="8" Time="2013-07-23 10:51:47Z" Version="15.00.0516.014">
      <?xml version="1.0" encoding="utf-8"?>
      <soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:m="http://schemas.microsoft.com/exchange/services/2006/messages" xmlns:t="http://schemas.microsoft.com/exchange/services/2006/types" xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
        <soap:Header>
          <t:RequestServerVersion Version="Exchange2010_SP2" />
          <t:ExchangeImpersonation>
            <t:ConnectingSID>
              <t:SmtpAddress>HBuckle@blah</t:SmtpAddress>
            </t:ConnectingSID>
          </t:ExchangeImpersonation>
        </soap:Header>
        <soap:Body>
          <m:AddDelegate>
            <m:Mailbox>
              <t:EmailAddress>HBuckle@blah</t:EmailAddress>
            </m:Mailbox>
            <m:DelegateUsers>
              <t:DelegateUser>
                <t:UserId>
                  <t:PrimarySmtpAddress>MSTest@blah</t:PrimarySmtpAddress>
                </t:UserId>
                <t:DelegatePermissions>
                  <t:CalendarFolderPermissionLevel>Editor</t:CalendarFolderPermissionLevel>
                  <t:TasksFolderPermissionLevel>None</t:TasksFolderPermissionLevel>
                  <t:InboxFolderPermissionLevel>None</t:InboxFolderPermissionLevel>
                  <t:ContactsFolderPermissionLevel>None</t:ContactsFolderPermissionLevel>
                  <t:NotesFolderPermissionLevel>None</t:NotesFolderPermissionLevel>
                  <t:JournalFolderPermissionLevel>None</t:JournalFolderPermissionLevel>
                </t:DelegatePermissions>
                <t:ReceiveCopiesOfMeetingMessages>false</t:ReceiveCopiesOfMeetingMessages>
                <t:ViewPrivateItems>false</t:ViewPrivateItems>
              </t:DelegateUser>
            </m:DelegateUsers>
            <m:DeliverMeetingRequests>DelegatesOnly</m:DeliverMeetingRequests>
          </m:AddDelegate>
        </soap:Body>
      </soap:Envelope>
    </Trace>
    

    <Trace Tag="EwsResponse" Tid="8" Time="2013-07-23 10:51:48Z" Version="15.00.0516.014">
      <?xml version="1.0" encoding="utf-8"?>
      <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/">
        <s:Header>
          <h:ServerVersionInfo MajorVersion="14" MinorVersion="2" MajorBuildNumber="328" MinorBuildNumber="9" Version="Exchange2010_SP2" xmlns:h="http://schemas.microsoft.com/exchange/services/2006/types" xmlns="http://schemas.microsoft.com/exchange/services/2006/types" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" />
        </s:Header>
        <s:Body xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
          <m:AddDelegateResponse ResponseClass="Success" xmlns:m="http://schemas.microsoft.com/exchange/services/2006/messages" xmlns:t="http://schemas.microsoft.com/exchange/services/2006/types">
            <m:ResponseCode>NoError</m:ResponseCode>
            <m:ResponseMessages>
              <m:DelegateUserResponseMessageType ResponseClass="Success">
                <m:ResponseCode>NoError</m:ResponseCode>
                <m:DelegateUser>
                  <t:UserId>
                    <t:SID>S-1-5-21-1527477058-408891036-1093625069-14540</t:SID>
                    <t:PrimarySmtpAddress>MSTest@blah</t:PrimarySmtpAddress>
                    <t:DisplayName>MSTest</t:DisplayName>
                  </t:UserId>
                  <t:ReceiveCopiesOfMeetingMessages>false</t:ReceiveCopiesOfMeetingMessages>
                  <t:ViewPrivateItems>false</t:ViewPrivateItems>
                </m:DelegateUser>
              </m:DelegateUserResponseMessageType>
            </m:ResponseMessages>
          </m:AddDelegateResponse>
        </s:Body>
      </s:Envelope>
    </Trace>
    

    Wednesday, July 31, 2013 5:21 AM

All replies

  • Has anyone got any thoughts on this, i'm not sure if it's a bug in the API or because i'm doing something wrong?
    Tuesday, August 6, 2013 5:56 AM