locked
VS2012: intellisense not working for JS RRS feed

  • Question

  • Hi there.

    In VS2012, in .NET projects, I can begin typing a class name and hit '.' and it will accept the autocomplete choice and have my '.' but in the javascript editor in 2012, doing the same thing seems not to accept the autocomplete choice, and I end up with the first part of the class name followed by a '.'. Is this configurable? Is it inconvenient to anyone else?

    -Ben


    • Edited by Mike FengModerator Friday, September 14, 2012 2:34 AM make the title match the content
    Thursday, September 13, 2012 6:35 PM

Answers

  • Hi Benji,

    I reproduced this scenario.

    You can change this behavior this way:

    1. Go to the Tools menu.

    2. Go to the Options... submenu.

    3. Find Text Editor node.

    4. Find JavaScript subnode.

    5. Go deep to IntelliSense subnode.

    6. Uncheck the option "Only use Tab or Enter commit".

    7. Done.

    Best regards,


    Mike Feng
    MSDN Community Support | Feedback to us
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Benji22 Friday, September 14, 2012 12:11 PM
    Friday, September 14, 2012 8:27 AM
    Moderator

All replies

  • Hi Benji,

    Welcome to the MSDN Forum.

    I have modified your thread title to make it more related to the content.

    Where do you code this JS code?

    I have tried it in .js file in VS2012 RTMrel. And it works well.

    Please take a look at this similar thread: http://forums.iis.net/t/1190016.aspx 

    Best regards,


    Mike Feng
    MSDN Community Support | Feedback to us
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, September 14, 2012 2:50 AM
    Moderator
  • In VS2012 RTM, just create a new ASP.NET project (any type), and add a new javascript file. Create a function. Then in another function type the beginning of its name to bring up intellisense. If you've typed half the name, hit period, and it will not select the selected option. If you don't get this, please give me steps to follow.

    Friday, September 14, 2012 3:17 AM
  • Hi Benji,

    I reproduced this scenario.

    You can change this behavior this way:

    1. Go to the Tools menu.

    2. Go to the Options... submenu.

    3. Find Text Editor node.

    4. Find JavaScript subnode.

    5. Go deep to IntelliSense subnode.

    6. Uncheck the option "Only use Tab or Enter commit".

    7. Done.

    Best regards,


    Mike Feng
    MSDN Community Support | Feedback to us
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Benji22 Friday, September 14, 2012 12:11 PM
    Friday, September 14, 2012 8:27 AM
    Moderator
  • Thanks, Mike!!

    -Ben

    Friday, September 14, 2012 12:11 PM