none
Changed VBA no longer runs from Outlook rule RRS feed

  • Question

  • A while ago I created a rule in Outlook that calls a VBA script.  When originally set up, I had some issue getting the VBA to run until I changed the security for macros through the Trust Center to prompt for all macros.  After this, the rule worked and the VBA executed just fine. It's been several months without any issues.

    I recently made a change to the VBA and the script no longer executes.  I put a break point on the first line and it doesn't even get there when I run the rule manually.  I tried changing the macro security options (including enable all macros) and nothing will get the VBA to run.  I know the rule runs because it will execute other parts of the rule (moving the email to a folder).

    I also tried adding a self-generated certificate and still nothing.

    Any ideas?

    Thanks in advance.

    Thursday, October 31, 2013 7:04 PM

All replies

  • If you restore the code before, does the rule can work? I tried changing the rule, it worked successfully for me.

    Have you tried create a new rule to see whether it work for you ?

    Sunday, November 3, 2013 4:47 PM
  • I put back the original VBA and it still doesn't run.  I also tried creating a new rule and it still doesn't run.  I even tried creating a new macro and that didn't run either.

    It seems like the security isn't set properly?

    Monday, November 4, 2013 7:09 PM