locked
Update process of XAP does not work as it should RRS feed

  • Question

  • I have several previous releases of my App. The last one was Version 2.0. Now I would like to update the XAP. I select the App icon and then the dialog "Upload and describe your XAP" is coming up. There I have selected 2.0 and selected "Update selected". Then I have uploaded my XAP. Now in contrast to the previous release process the shown "XAP version number" did not change from 2.0 to 2.1 (the new Version is 2.1). To me this is confusing. I have no visual feedback if the upload went fine. Am I now expected to change the version manually?

    • Edited by Tron 42 Monday, August 27, 2012 2:03 PM
    Monday, August 27, 2012 1:55 PM

Answers

  • You are correct, the Version Number does not get updated automatically when you click 'Update' and upload a new XAP file.  If you do not see an error, the upload will have completed successfully. To update the Version, you will need to manually change the version number and click save. 

    • Proposed as answer by Malin De Silva Wednesday, September 12, 2012 6:46 PM
    • Marked as answer by Danny G. - MS Friday, October 19, 2012 9:16 PM
    Wednesday, September 12, 2012 3:53 PM

All replies

  • XAP errorsDuplicate version: you’ve already published this XAP. If you have updates, make changes to your XAP and submit an update.Missing required metadata: DescriptionMissing required metadata: Tile icconMissing required metadata: Screenshot WVGA

    On "In progress" I can see three Apps with the Versions 1.6, 2.0, 1.0. Where are they coming from? From pervious attempts? Can I savely delete the Apps from the "In progress" page?

    Update: Now I have deleted the "In progress" Apps and restarted the process. I just uploaded the XAP and still the version number did not change. Now I have closed the IE and reopened the Dashboard. Now I see "In progress" Version 1.6 (where ever this is coming from) and the uploaded Version 2.1. Finally it was possible to select this version and to submit it as an update. I had to create a new 300x300px logo but I guess this is something I was not aware off. I think the problem is that after the upload of the XAP the silverlight interface does not switch to the uploaded App for editing - at least this is my impression.

    • Edited by Tron 42 Monday, August 27, 2012 3:49 PM
    Monday, August 27, 2012 2:12 PM
  • Yep, the current UI seems little confusing. After updating the XAP, the version info still shows the old package's version. There's no indication at all if the XAP was successfully uploaded.

    And to add to the confusion, the text box for the XAP version is editable. I'm not sure if I should manually insert the new version using the provided text boxes.

    Wednesday, September 12, 2012 12:03 PM
  • You are correct, the Version Number does not get updated automatically when you click 'Update' and upload a new XAP file.  If you do not see an error, the upload will have completed successfully. To update the Version, you will need to manually change the version number and click save. 

    • Proposed as answer by Malin De Silva Wednesday, September 12, 2012 6:46 PM
    • Marked as answer by Danny G. - MS Friday, October 19, 2012 9:16 PM
    Wednesday, September 12, 2012 3:53 PM
  • In my opinion it is not only the update of the version number alone. On the page you have a select box for the xap to update. You upload the xap and the problem is that the select box is not updated then (no new entry in the box. The entries in the select box are also hard to differentiate because the version number is missing there too). Thus all the text and all the changes you then make will apply to a previous xap (you can only select the old ones in the select box). The workaround is to upload the new xap only. Then you logoff and logon and then the select box will also show the new xap. Now you can select this new xap. This will allow to continue by entering all the missing data and screenshots belonging to this new version. At least this was my experience.



    • Edited by Tron 42 Thursday, September 13, 2012 5:06 PM
    Thursday, September 13, 2012 5:03 PM
  • Had the same confusion since the Version No. did not update.

    Also the Version textboxes are designed such that they appear to be Disabled Textboxes. From Rick's comment above I realized I can update it manually. After doing that and going back to dashboard, the app showed my app's correct version.

    One other clue if the new XAP was upload is checking the File Size under the Version textboxes. For me my first version was 13Mb and after upload it updated it to the new size, 16Mb.

    Thanks all.


    Check out our app - Trekstir Lite Children's Books - with unique and original stories.

    Friday, October 12, 2012 2:57 AM