locked
How to configure Visual Studio 2015 iis to run as local server? RRS feed

  • Question

  • User2142845853 posted

    I have an MVC app that needs to be tested locally before deployment to the server, did this before with VS2013 and it worked fine.  Now in VS2015 it doesnt work, and an error shows up saying the port is not running and it stops.   The goal is to make it run so the IP and port# are used to access the iis express server

    Before in the applicationhost.config file found within   /documents the line below was modified; Now in VS2015 they moved this file into the .vs file in the project folder, but i changed the same exact line: 

    <bindings>
    <binding protocol="http" bindingInformation="*:43071:10.103.123.025" />
    </bindings>

    then go into firewall settings and add an exception with the port number, run, open browser and type in 10.103.123.025:43071  and there is the website.  anyone on the local network could access it fine.

    in the OLD visual studio it worked.  in VS2015 it fails,  click Run, few seconds  a popup dialog with:   port 12345 is not running  click Here for information about (something).  i looked at every link and still dont understand what it takes to make the VS2015 iis express allow external web pages

    thanks

    Tuesday, August 18, 2015 11:39 AM

Answers

  • User614698185 posted

    Hi rogersbr,

    According to your description, I think you can reconfigure Visual Studio 2015 IIS by following steps:

    1) In Solution Explorer, right click the your project and click Properties.

    2) In the left tab, click Web.

    3) Select IIS Express, check out your Project Url, then create Virtual Directory.

    I hope this will help you.

    Best Regards,

    Candice Zhou

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, August 19, 2015 4:27 AM
  • User614698185 posted

    Hi rogersbr,
    According to your description, I think you may miss a binding information entry in applicationhost.config file.
    I think you can check out your config file by following steps:
    1.Open your applicationhost.config file. Possible locations are:

    %userprofile%\Documents\IISExpress\config\applicationhost.config
    $(solutionDir)\.vs\config\applicationhost.config (VS2015)

    Failing that, inspect the output from iisexpress.exe to be sure.

    2.Locate your WebSite entry and add following binding with your machine name.

    <bindings>    
    <binding protocol="http" bindingInformation="="*:43071:10.103.123.025" /> <!-- This will be here already -->
    <binding protocol="http" bindingInformation="*:8080:windows" /> <!-- Add this -->
    </bindings>

    3.Restart IIS Express
    I hope this will help you.
    Best Regards,
    Candice Zhou

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, August 21, 2015 4:24 AM

All replies

  • User614698185 posted

    Hi rogersbr,

    According to your description, I think you can reconfigure Visual Studio 2015 IIS by following steps:

    1) In Solution Explorer, right click the your project and click Properties.

    2) In the left tab, click Web.

    3) Select IIS Express, check out your Project Url, then create Virtual Directory.

    I hope this will help you.

    Best Regards,

    Candice Zhou

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, August 19, 2015 4:27 AM
  • User2142845853 posted

    Hi Candice

    yes i tried that, but it throws an error message:

    ok i cannot insert images for some reason, but it says unable to create the virtual directory.  cannot create the web site http://  ..... you must specify "localhost" for the server name

    and I do not know why it was possible to override the settings for visual studio 2013 as mentioned and it worked perfectly, but in vs2015 it doesnt

    Wednesday, August 19, 2015 8:36 AM
  • User2142845853 posted

    Hi Candice

    i rechecked the apphost file, and it had (as it will) reinserted the localhost entry, so i changed that to the ip and port.  then did the settings you described, this time it was successful.  ran the project but noticed that 1.  the system monitor showed 11Mb of memory use where my app runs to 90mb really fast then goes up;  2.  the URL did not work, connection refused (or nothing there)

    rechecked the firewall and its set to allow that port.  after trying more changes, i crashed VS2015 by modifying those web settings in project

    edit:  when i put the IP in to the project/web/Servers/ project Url both checkboxes not checked, and run its at 11Mb useage.  solid.  change to localhost and my app does run, it climbs to 91mb then over 100mb and its nonlinear, increasing as it does (whatever)

    Wednesday, August 19, 2015 8:55 AM
  • User2142845853 posted

    maybe the problem was my firewall.

    Im running Windows 7, but have had some issues trying to add or modify the rules.  its set and saved and should have worked;  maybe i needed to set the rules then restart windows?

    but i used old settings from the old port# from the VS2013 project and it runs.  annoying and what a waste of time

    Wednesday, August 19, 2015 12:51 PM
  • User614698185 posted

    Hi rogersbr,
    According to your description, I think you may miss a binding information entry in applicationhost.config file.
    I think you can check out your config file by following steps:
    1.Open your applicationhost.config file. Possible locations are:

    %userprofile%\Documents\IISExpress\config\applicationhost.config
    $(solutionDir)\.vs\config\applicationhost.config (VS2015)

    Failing that, inspect the output from iisexpress.exe to be sure.

    2.Locate your WebSite entry and add following binding with your machine name.

    <bindings>    
    <binding protocol="http" bindingInformation="="*:43071:10.103.123.025" /> <!-- This will be here already -->
    <binding protocol="http" bindingInformation="*:8080:windows" /> <!-- Add this -->
    </bindings>

    3.Restart IIS Express
    I hope this will help you.
    Best Regards,
    Candice Zhou

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, August 21, 2015 4:24 AM