none
Tracking data not displaying in BizTalk Server 2016 Admin Console RRS feed

  • Question

  • Tracking for all BizTalk artifacts has been enabled but nothing shows up in the BizTalk Admin Console. 

    Where do I begin to troubleshoot? Data is being written to BizTalk MsgBoxDb TrackingData_0_* tables and DTA Purge and Archive job is working without issues. SQL database is on remote server. 

    I am thinking this may be permissions related. What user accounts should belong to what groups for data to be viewed?

    Thanks.

    Thursday, March 22, 2018 3:12 PM

Answers

  • Adding the Host service account to BizTalk Server Administrators Group solved our issue.
    • Marked as answer by guett-v Friday, May 11, 2018 2:38 PM
    Friday, May 11, 2018 2:37 PM

All replies

  • is there a tracking host instance that is running?

    Mandar Dharmadhikari

    Thursday, March 22, 2018 4:04 PM
    Moderator
  • Yes - tracking host instances are created and running. I have tried recreating the host and host instances, but this doesn't seem to make a difference.
    Thursday, March 22, 2018 5:40 PM
  • Are all Agent Jobs running correctly?

    If you're looking for data on the default Pipelines, that has to be enabled in BizTalk.System, but you shouldn't be doing that. Instead: BizTalk: Improve Deployment and Tracking by Always Creating Custom Pipelines

    Thursday, March 22, 2018 6:58 PM
    Moderator
  • Agreed. I am trying to verify new environment config and have enabled tracking for all artifacts temporarily. Is there a way to query the database directly to pull back tracking data?
    Thursday, March 22, 2018 8:01 PM
  • We have finally narrowed down the issue to the service account, but still not sure what changes are needed to have the tracking working for the host service account.

    The host service account belongs to the following groups:

    • BizTalk Application Users
    • BizTalk SSO Affiliate Administrators

    Does it need to belong to any other groups? Are there permissions on the database that we need to check? Other?

    Any help is appreciated.

    Thanks.

    Tuesday, April 10, 2018 3:54 PM
  • How do you know the issue is related to the Service Account?

    Any Permissions problems would result in a hard error.

    Tuesday, April 10, 2018 7:56 PM
    Moderator
  • Is Global tracking ON?

    Also, you see data in the TrackingData_1_* tables (couple of them) in MsgBoxDB?


    Thanks Arindam

    Tuesday, April 10, 2018 8:59 PM
    Moderator
  • Adding the Host service account to BizTalk Server Administrators Group solved our issue.
    • Marked as answer by guett-v Friday, May 11, 2018 2:38 PM
    Friday, May 11, 2018 2:37 PM