locked
Request failed with status code '413' and status text 'Request Entity Too Large'. RRS feed

  • Question

  • I have a 2013 Lightswitch html app and while attempting to add a number of rows to a table with image data the server throws an error.  I can handle about 2Mb but after that it fails with the message

    Request failed with status code '413' and status text 'Request Entity Too Large'.

    It does not seem to matter if I change the value in the web.config

    <httpRuntime maxRequestLength="102400"/>

    Any ideas?

    Thursday, March 13, 2014 9:35 AM

Answers

  • Found it, for Lightswitch the setting is 

    <webHttpBinding>
      <binding maxReceivedMessageSize="65536000" />
    </webHttpBinding>

    With regard to the suggestions, the maxRequestLength is already big, the timeout was not hit when I ran it locally and the maxItemsInObjectGraph had no effect.

    maxReceivedMessageSize is in bytes by the way.

    • Marked as answer by Angie Xu Friday, March 21, 2014 7:21 AM
    Wednesday, March 19, 2014 4:26 AM

All replies

  • Hi Jif

    According to the error message, generally we could set the value of the  maxRequestLength and executionTimeout properties in the web.config file to enable large file sizes.

    <system.web>

    <httpRuntime maxRequestLength="102400" executionTimeout="120" />

    </system.web>

    hope it helps.

    Regards


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, March 18, 2014 10:52 AM
  • They are both stabs in the dark, but, are you using SSL?  If so, this might apply:

    http://forums.iis.net/t/1169257.aspx

    Also, this might apply.  Find a setting in your web.config called "maxItemsInObjectGraph", and add a zero to the end.  See if that changes anything.

    Tuesday, March 18, 2014 8:29 PM
  • Found it, for Lightswitch the setting is 

    <webHttpBinding>
      <binding maxReceivedMessageSize="65536000" />
    </webHttpBinding>

    With regard to the suggestions, the maxRequestLength is already big, the timeout was not hit when I ran it locally and the maxItemsInObjectGraph had no effect.

    maxReceivedMessageSize is in bytes by the way.

    • Marked as answer by Angie Xu Friday, March 21, 2014 7:21 AM
    Wednesday, March 19, 2014 4:26 AM