locked
Incorrect page number in footer in report viewer RRS feed

  • Question

  • Hi,

                I have defined "page x of y" in my report footer that shows correctly the no. of pages when i export it into pdf but in report viewer it shows 1 of 1"pages  inspite of having many pages.What is the problem with it & How can i resolve it?

    Awaiting for Reply,

     

    Thursday, December 17, 2009 8:20 AM

Answers

  • Sorry for the late reply. If you still haven't found the answer, on Report Layout tab, press F4 and a properties window comes up on the side. Under Layout, you will see this InteractiveSize. hth.
    Chicagoan ...
    • Marked as answer by Shaikh Sadaf Monday, February 8, 2010 6:39 AM
    Thursday, December 31, 2009 3:07 PM
    Answerer
  • Shaikh,

    In order to see the same number of pages between Report Viewer and when you export them to Pdf, you need to set the InteractiveSize width and height to be the same as the PageSize settings. hth.
    Chicagoan ...
    • Marked as answer by Jerry Nee Friday, December 25, 2009 9:48 AM
    Thursday, December 17, 2009 4:57 PM
    Answerer

All replies

  • in the report click on the text box where you need page number and click expression, and click on globals you can see pages and total pages, this will help you to have page numbering. visit http://www.my-sql-share.blogspot.com
    Thursday, December 17, 2009 4:32 PM
  • Shaikh,

    In order to see the same number of pages between Report Viewer and when you export them to Pdf, you need to set the InteractiveSize width and height to be the same as the PageSize settings. hth.
    Chicagoan ...
    • Marked as answer by Jerry Nee Friday, December 25, 2009 9:48 AM
    Thursday, December 17, 2009 4:57 PM
    Answerer
  • Hi there,
               can u just tel me where can i get this "InteractiveSize" property in sql reporting

    Awaiting for reply
    Sunday, December 27, 2009 11:32 AM
  • Sorry for the late reply. If you still haven't found the answer, on Report Layout tab, press F4 and a properties window comes up on the side. Under Layout, you will see this InteractiveSize. hth.
    Chicagoan ...
    • Marked as answer by Shaikh Sadaf Monday, February 8, 2010 6:39 AM
    Thursday, December 31, 2009 3:07 PM
    Answerer