none
Remapping Web Folder Changing IIS App Pool RRS feed

  • Question

  • We are using VS 2010 with TFS and have a few WCF projects. We also use TFS's Branching feature.  The WCF projects are set up to use the Local IIS Web server.  Each site has a custom Application Pool.

    When I open a branch solution, I receive a dialog that says something like

    "The Web project 'TestService' is currently configured to use the URL 'http://localhost/TestService".  The Web server has this URL mapped to a different folder.  Would you like to remap this URL to point to this Web project's folder?"

    If I say Yes to this dialog, it changes the physical path but it also changes the Application Pool to the ASP.NET v4.0 pool instead of the custom pool that is set up, but I do not know what is causing this behavior. 

    Tuesday, July 1, 2014 3:01 PM

Answers

  • Hi,

    >>"The Web project 'TestService' is currently configured to use the URL 'http://localhost/TestService".  The Web server has this URL mapped to a different folder.  Would you like to remap this URL to point to this Web project's folder?"

    When occur the above problem, please try to check the following two solution:

    a) Please update the url of the project and create a new virtual directory for the project(for example change the http://localhost/TestService to http://localhost/TestService1)

    OR

    b) Please update the path of the site that you have already configured by navigating to inetmgr and then updating the path to the new location.

    Best Regards,
    Amy Peng


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.




    Wednesday, July 2, 2014 3:36 AM
    Moderator

All replies

  • If I say Yes to this dialog, it changes the physical path but it also changes the Application Pool to the ASP.NET v4.0 pool instead of the custom pool that is set up, but I do not know what is causing this behavior.

    And neither does anyone else knows this either, becuase this is an IIS issue. Maybe you should try the fourm link below.

    http://forums.iis.net/

    Tuesday, July 1, 2014 5:16 PM
  • Hi,

    >>"The Web project 'TestService' is currently configured to use the URL 'http://localhost/TestService".  The Web server has this URL mapped to a different folder.  Would you like to remap this URL to point to this Web project's folder?"

    When occur the above problem, please try to check the following two solution:

    a) Please update the url of the project and create a new virtual directory for the project(for example change the http://localhost/TestService to http://localhost/TestService1)

    OR

    b) Please update the path of the site that you have already configured by navigating to inetmgr and then updating the path to the new location.

    Best Regards,
    Amy Peng


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.




    Wednesday, July 2, 2014 3:36 AM
    Moderator