none
VS2015 line numbers

    General discussion

  • seems in the last few months VS2015 no longer remembers my setting for displaying lines numbers. personally I want line numbers on everything. but it won't remember my setting on any solution or project no matter how many times I change it. 

    any ideas?

    Tuesday, February 07, 2017 11:27 PM

All replies

  • Hi,

    Welcome to MSDN forum.

    Please check if you have select the currentsetting.vssettings to save your settings automatically like the following screenshots:

    After you have enabled line numbers in the editor Tools->Options->Text Editor->All Languages->General-> Line numbers-> click ok, and then please click tools->import and Export settings->select import selected environment settings->select import CurrentSettings.vsettings

    Besides, please open Windows Explorer, and navigate C:\Program Files or Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE), and run the following commands: devenv.exe /safemode to open visual studio and then you could check if the issue persists. If everything is ok, the issue may be caused by some extension and you need to remove the installed extensions under Tools—Extensions and Updates.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, February 08, 2017 8:28 AM
  • Thank you for your reply.

    Seems to be more to it than just the vssettings file. And I have a similar problem with the Start page.

    Line numbers stay on regardless of safe mode or not. I open multiple solutions and change solutions frequently. Appears that the settings get reset to the default at some point when switching or changing solutions. So far cannot see any pattern.  All of a sudden line numbers are gone.

    And, I like to have the Start page up.  I open, pin it, restore it, move it back, but VS 2015 seems insistent on ignoring my settings.  For example, while testing if line numbers stay on, I re-enabled line numbers for all files, opened and pinned the Start page (next to a couple of file tabs) then closed the solution.  On reopening the solution, the line numbers settings was still enabled for all files but the Start page was gone. In an attempt to eliminate variables, only one solution was open at a time. What is the point of pinning if VS 2015 ignores it?


    Monday, March 13, 2017 1:57 PM
  • Just opened another solution - Start page and line numbers are gone!  

    VS2015 is randomly and ambiguously ignoring whatever settings we make.

    Monday, March 13, 2017 2:10 PM