none
MQSeries adapter can't handle Inorder RRS feed

  • Question

  • Hi!

    I'm running BTS 2010 and we are about to implement a WMQ 7.5 Server setup. Everything works fine for both stand alone setup and cluster (MS Failover Cluster) for WMQ but we are not able to get the MQSeries adapter to keep Inorder.

    The problem seems isolated to the Receive port FROM the WMQ queue to BTS using the MQSeries adapter. Test sending 10.000 messages about 200 are not Inorder.

    I think something with the MSDTC on the WMQ servers are causing this since when we select "Transaction Supported: No" for the MQSeries adapter we will have the messages Inorder (tested with 200.000 msg). "Threads" and "Maximum Messages in batch" is set to "1".

    The setup of DTC on the WMQ is according to all documentations I've found so far and look like the attached picture.

    No errors in WMQ error logs or any of the application/system logs for WMQ/BTS.

    The WMQ queue is also configured as "FIFO".

    Any suggestions or experience?

    WMQ DTC

    Regards,
    Pontus

    Friday, November 8, 2013 12:45 PM

Answers

  • You only need to have the Allow Remote Administration checked if you actually want to allow that.  You don't need SNA LU 6.2 Transactions.

    The authentication settings can be set at your discretion.

    How are you determining the messages are out of order?

    • Marked as answer by Pengzhen Song Friday, November 15, 2013 8:15 AM
    Monday, November 11, 2013 1:00 PM

All replies