locked
Server Error in '/' Application RRS feed

  • Question

  • User673203190 posted

    Newbie to asp.net.   I am trying to get a new ClubSite website running on GoDaddy but continue to get this error.  My continual correcting of the connectionString doesn't seem to make any difference.  I've pasted a portion of my web.config below the error message in hopes that somebody can tell me what's wrong or where to look.

     Thanks for the help!

    Chuck

     

     

    The SSE Provider did not find the database file specified in the connection string. At the configured trust level (below High trust level), the SSE provider can not automatically create the database file.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.Configuration.Provider.ProviderException: The SSE Provider did not find the database file specified in the connection string. At the configured trust level (below High trust level), the SSE provider can not automatically create the database file.

    Source Error:

    Line 4:  
    Line 5:  	Sub Application_Start(ByVal sender As [Object], ByVal e As EventArgs)
    Line 6:  		If (Roles.RoleExists("Administrators") = False) Then
    Line 7:  			Roles.CreateRole("Administrators")
    Line 8:  		End If

    Source File: d:\hosting\wildwesthd1957\global.asax    Line: 6

    Stack Trace:

    [ProviderException: The SSE Provider did not find the database file specified in the connection string. At the configured trust level (below High trust level), the SSE provider can not automatically create the database file.]
       System.Web.DataAccess.SqlConnectionHelper.EnsureSqlExpressDBFile(String connectionString) +2555237
       System.Web.DataAccess.SqlConnectionHelper.GetConnection(String connectionString, Boolean revertImpersonation) +87
       System.Web.Security.SqlRoleProvider.RoleExists(String roleName) +482
       System.Web.Security.Roles.RoleExists(String roleName) +242
       ASP.global_asax.Application_Start(Object sender, EventArgs e) in d:\hosting\wildwesthd1957\global.asax:6
    

     

     

    <connectionStrings><remove name="LocalSqlServer"/>

    <add name="SiteSqlServer"

    connectionString="Server=whsql-v23.prod.mesa1.secureserver.net;Database=wildwesthd1957;Uid=wildwesthd1957;Pwd=********"

    providerName="System.Data.SqlClient" />

    <add key="SiteSqlServer" value="Server=whsql-v23.prod.mesa1.secureserver.net;Database=wildwesthd1957;Uid=wildwesthd1957;Pwd=********"/>

    </connectionStrings>

    <system.web>

    <roleManager enabled="true"/>

    <authentication mode="Forms" />

    <compilation debug="true" strict="true">

    <assemblies>

    <add assembly="System.Xml, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>

    <add assembly="System.Messaging, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>

    <add assembly="System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>

    </assemblies>

    </compilation>

    <membership defaultProvider="AspNetSqlMembershipProvider"/>

    <siteMap defaultProvider="AspNetXmlSiteMapProvider" enabled="true">

    <providers>

    <remove name="AspNetXmlSiteMapProvider"/>

    <add name="AspNetXmlSiteMapProvider" description="SiteMap provider which reads in .sitemap XML files." type="System.Web.XmlSiteMapProvider" securityTrimmingEnabled="true" siteMapFile="Web.sitemap"/>

    </providers>

    </siteMap>

    <!-- 2/20/08 changed customErrors

    <customErrors defaultRedirect="~/ErrorPage.htm" /> -->

    <customErrors mode="Off" />

    <globalization requestEncoding="utf-8" responseEncoding="utf-8"/>

    </system.web>

     

    Friday, February 22, 2008 9:35 PM

All replies

  • User487807879 posted

    In web.config file change this lines (bold is important):

    <roleManager enabled="true"/>
    <membership defaultProvider="AspNetSqlMembershipProvider"/>
    with this:
    <roleManager enabled="true" defaultProvider="AspNetSqlRoleProvider">
       <providers>
        <clear/>
        <add connectionStringName="SiteSqlServer" applicationName="/" name="AspNetSqlRoleProvider" type="System.Web.Security.SqlRoleProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
        <add applicationName="/" name="AspNetWindowsTokenRoleProvider" type="System.Web.Security.WindowsTokenRoleProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
       </providers>
      </roleManager>


    <membership defaultProvider="AspNetSqlMembershipProvider">
       <providers>
        <clear/>
        <add name="AspNetSqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" connectionStringName="SiteSqlServer" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="false" applicationName="/" requiresUniqueEmail="false" minRequiredPasswordLength="4" minRequiredNonalphanumericCharacters="0" passwordFormat="Hashed" maxInvalidPasswordAttempts="5" passwordAttemptWindow="10" passwordStrengthRegularExpression="^([1-zA-Z0-1@.\s]{1,255})$"/>
       </providers>
      </membership>

    Saturday, February 23, 2008 7:03 AM
  • User-2005691517 posted

    The SSE Provider did not find the database file specified in the connection string. At the configured trust level (below High trust level), the SSE provider can not automatically create the database file.

     You are using the default role provider which requires the database to be present in the app_data folder of your web application. Normally, this gets created automatically in case it is not present.

    In your case though (as is evident by the error message), the application does not have enough rights to create this database. You can try copying the database file into the app_data folder.

    Saturday, February 23, 2008 7:05 AM