locked
Could not load type 'BEE.Web.Global'. RRS feed

  • Question

  • User1052662409 posted

    Hi All,

    I got an application from my someone with sln file. This is first time I am doing this. I am trying to run this on my machine but when I run it it shows error "Could not load type 'BEE.Web.Global'."

    Even I tried to add references to the application. Some references gets add but some not and ends with some error like "circular dependency".

    I never run projects using .sln file. Please suggest how to do that. For reference here I have pasted my solution explorer.

    Thanks

    Tuesday, August 23, 2016 9:53 AM

All replies

  • User954927490 posted

    Hi,

    First try to build every project in the solution individually, if all are build successfully make BEE.Web startup project and run.
    I think the problem is in the global.asax file of BEE.web may be some name space is missing from global.asax file. To check this right click on global.asax fine on solution explorer and click on "view Markup"

    Tuesday, August 23, 2016 10:34 AM
  • User-2057865890 posted

    Hi Demoninside9,

    These errors occur if the .aspx page or the Global.asax page contains a reference to a code-behind module and if the application has not been built. You could clean and build solution.

    reference:

    https://support.microsoft.com/en-us/kb/306155

    Best Regards,

    Chris

    Wednesday, August 24, 2016 4:13 AM
  • User1052662409 posted

    https://support.microsoft.com/en-us/kb/306155

    csc /t:library /r:System.web.dll /out:<var class="sbody-var">mydll</var>.dll <var class="sbody-var">myfile</var>.cs

    show solution by compiling the files, but in my project there is no dll.

    Thanks

    Gaurav

    Wednesday, August 24, 2016 7:34 AM
  • User-166373564 posted

    Hi,

    Here are a few suggestions that might help:

    •Cleaning and rebuilding your current Project (Right-click > Clean, Right-click Rebuild respective) and see if that makes any difference at all. 

    •Stop your existing application and ensure that you don't have any additional IIS processes or instances of your local Web Server running.

    •If these issues are still persisting after the above steps, try restarting Visual Studio (and even your local machine)

    • If you are dealing with multiple Projects, ensure that the Project that you have a breakpoint in is actually running (Right-click your Solution > Set Startup Projects... > Ensure your current Project is selected)

    After you try suggestions above, you could add a Project Reference to a Visual Studio Web Project again, check whether it can fix it.

    Regards,

    Angie

    Wednesday, August 31, 2016 7:20 AM