locked
deployment error? RRS feed

  • Question

  • User-1234271576 posted

    when am doing deployment,am getting this error,can you please clear it for me,what is the meaning of it?and how should i clear this error?

    Error 2 Web deployment task failed.(Could not complete the request to remote agent URL 'https://newonlineexam:8172/msdeploy.axd?site=Default Web Site'.)

    Could not complete the request to remote agent URL 'https://newonlineexam:8172/msdeploy.axd?site=Default Web Site'.
    The remote name could not be resolved: 'newonlineexam' 0 0 newonlineexam

    Monday, June 3, 2013 5:51 AM

Answers

  • User-801004448 posted

    Web deploy link does not work

    https://newonlineexam:8172

    newonlineexam is probably your machine name. You can try replacing "newonlineexam" with your computer IP address.

    Where do you want to publish website to?

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, June 5, 2013 2:25 AM

All replies

  • User-1635195291 posted

    Hi There,

    I am not sure exactly what is causing this error but i would like you to follow any of the following methods. Hopefuly this will help you things sorted out.

    Make sure you have the WMSvc Service (Web Management Service) set to 'Auto' (and started) so it's on when you restart & check out this link http://learn.iis.net/page.aspx/516/configure-the-web-deployment-handler/

    or

    1. When installing/reinstalling the WebDeploy installer, choose Custom/Change and then ensure that 'Management Service Delegation UI' is one of the installed options, it is not installed by default, but is required for WebDeploy to work (installer bug).
    2. Use the new Management Service Delegation icon in the Server node of the IIS manager to add the 'Deploy Applications with Content' role, accepting it's default settings. But you may also want to specify a "Run As" setting with a user that has rights to modify IIS settings.
    3. Restart the Web Management Service.

    or

    http://forums.iis.net/t/1193783.aspx/1

    Hope you will clear that error through any of those.

    Thanks,

    Jatin

    Please "MARK AS ANSWER" if found helpful.

    Monday, June 3, 2013 10:12 PM
  • User311508580 posted

    Hi,

    1. You need to make sure you have starter web management service
    2. Enable publish setting for your user. Right click on your site--> configure web deploy-->fill your user details--> setup
    3. Try it again.

    Tuesday, June 4, 2013 11:36 PM
  • User311508580 posted

    Hi,

    1. You need to make sure you have starter web management service
    2. Enable publish setting for your user. Right click on your site--> configure web deploy-->fill your user details--> setup
    3. Try it again.

    Tuesday, June 4, 2013 11:36 PM
  • User-801004448 posted

    Web deploy link does not work

    https://newonlineexam:8172

    newonlineexam is probably your machine name. You can try replacing "newonlineexam" with your computer IP address.

    Where do you want to publish website to?

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, June 5, 2013 2:25 AM