locked
LightSwitch 2013: 403 - Forbidden: Access is denied RRS feed

  • Question

  • I just deployed a LightSwitch 2013 web application with success. But when I go to the URL, it says:

    403 - Forbidden: Access is denied.

    You do not have permission to view this directory or page using the
    credentials that you supplied.

    I've tried many of the suggestions in this forum with no success. I have some LightSwitch 2012 and earlier applications on the same webserver and their URL's work fine. So, I was wondering it was a problem in the publish settings. I have all of the proper needs (.Net 4.5 and all of the other suggestions and roles.)

    I am sure it is fairly simple. Any suggestions would be appreciated.
    Thursday, January 30, 2014 2:52 PM

Answers

  • Hi Brain,

    You may try the methods below:

    • If you are using a Silverlight web client, users browse to www.MySite.com/Client.
    • If you are using a Silverlight desktop client, users browse to www.MySite.com/DesktopClient.
    • If you are using an html client, users browse to www.MySite.com/HtmlClient.

    Please let me if it works.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, January 31, 2014 9:18 AM

All replies

  • Hi Brain,

    You may try the methods below:

    • If you are using a Silverlight web client, users browse to www.MySite.com/Client.
    • If you are using a Silverlight desktop client, users browse to www.MySite.com/DesktopClient.
    • If you are using an html client, users browse to www.MySite.com/HtmlClient.

    Please let me if it works.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, January 31, 2014 9:18 AM
  • Hi Brain,

    You may try the methods below:

    • If you are using a Silverlight web client, users browse to www.MySite.com/Client.
    • If you are using a Silverlight desktop client, users browse to www.MySite.com/DesktopClient.
    • If you are using an html client, users browse to www.MySite.com/HtmlClient.

    Please let me if it works.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    OK, this kind of worked for me. But here's the problem. All of my deployment settings are set to be a 100% web based application. But the only one that works is DesktopClient and it pushes out the desktop app. I need it to RUN from the web. What do I need to change to make this happen?
    Friday, January 31, 2014 9:53 PM
  • Hi Brain,

    You need to check the settings such as security, authentication and so on. You can refer to the article below:

    How to: Deploy a Three-Tier LightSwitch Application

    http://msdn.microsoft.com/en-us/library/gg481778.aspx

    Hope it helps.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, February 6, 2014 7:41 AM