locked
Windows Forms controls have been disabled RRS feed

  • Question

  • Is there a way to disable the message you get when a user clicks on a control when the page is zoomed

    "Windows forms controls have been disabled because the document has been scaled..."

    Thursday, February 4, 2010 10:24 PM

Answers

All replies

  • Friday, February 5, 2010 1:31 AM
  • That was by design as Aaron said. So is there any other help we can provide? If yes, just let us know.


    Best regards,
    Ji Zhou
    MSDN Subscriber Support in Forum
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Tuesday, February 9, 2010 2:10 AM
  • Thanks, I know that this is by design but Ideally I would be nice if the message could be disabled even if the contols cannot be used. 

    More importantly in excel I get this message when any sheet is zoomed even if the active one is not. I am able to use the control on the active sheet but if I try to click on a tab to switch sheets I get the message and the tab does not switch to the selected sheet.
    Tuesday, February 9, 2010 5:46 AM
  • The message cannot be disabled, it is there as a safety mechanism because WinForms controls do not scale very well when hosted inside Office.

    What version of Visual Studio and VSTO are you using? With Visual Studio 2008 and VSTO 3.0 I just tried zooming in on one sheet then switching to another and interacting with a WinForms controls. Everything works fine, as expected.

    I don't follow your problem regarding switching tabs either. I just tried to re-create this based on my interpretation of your problem and everything works fine. Can you be more clear with the steps you take to get to "I try to click on a tab to switch sheets I get the message and the tab does not switch to the selected sheet".

    Wednesday, February 10, 2010 6:12 AM
  • I have a workbook with 10 sheets sheet 1 is visible/active. Sheet 9 is "zoomed" If I click on any of the tabs to select another sheet I get the message. The only way I am able to select the sheet that is zoomed is to go to vba and use code to select it then I can put it back to 100%

    Wednesday, February 10, 2010 6:32 AM
  • I just finished running an Excel Workbook in Office 2007 built with Visual Studio 2008 and VSTO 3.0 that matches what you have described and I can switch tabs all day without the message. I tried zooming in on multiple sheets and different combinations of WinForms controls.

    Which version of Visual Studio and VSTO are you using?

    Also, can you reproduce this if you create a new Excel Workbook project in Visual Studio (Hello World flavor)? If you can (and can articulate the steps you took) it will help me to see the problem. If I can't reproduce it, I can't really help.
    Wednesday, February 10, 2010 4:23 PM