locked
SQL 2005 Client Tools install fails RRS feed

  • Question

  • Hi all... assisting with mass deployment of SQL 2005 Client Tools.

    Multiple users are able to pass the System Configuration Check, and click Next. It is on the next screen they see the following:

    Microsoft SQL Server 2005 Setup                              [_][X]
    -------------------------------------------------------------------
    Microsoft SQL Server Installation
      Setup is preparing to continue with the installation.
    -------------------------------------------------------------------
    Please wait while setup prepares to continue with the installation.

    Status: Extracting custom action file from stream
           ________________________________________________
          [________________________________________________]

    [Help]                                  [< Back] [Next >]  [Cancel]

    After eight minutes, the install bombs, and sends an error report to Microsoft.

    I saw a similar post here, but these are XP machines and Administrators appear to have the proper permissions. I also do not get the error message "Error writing to file".

    Here is a section of the _WI log file generated by the install..

    MSI (c) (48:A4) [09:20:49:208]: PROPERTY CHANGE: Adding ENABLERANU property. Its value is '1'.
    Action ended 9:20:49: SetEnableRanuUI. Return value 1.
    MSI (c) (48:A4) [09:20:49:208]: Skipping action: UnsetEnableRanuUI (condition is false)
    MSI (c) (48:A4) [09:20:49:208]: Skipping action: SetSharedVolumePath (condition is false)
    MSI (c) (48:A4) [09:20:49:208]: Skipping action: UnsetINSTALLSQLDATADIR (condition is false)
    MSI (c) (48:A4) [09:20:49:208]: Doing action: StreamSupportFiles.D20239D7_E87C_40C9_9837_E70B8D4882C2
    Action 9:20:49: StreamSupportFiles.D20239D7_E87C_40C9_9837_E70B8D4882C2. Extracting custom action file from stream
    Action start 9:20:49: StreamSupportFiles.D20239D7_E87C_40C9_9837_E70B8D4882C2.
    MSI (c) (48:44) [09:20:49:223]: Invoking remote custom action. DLL: C:\DOCUME~1\axn4835a\LOCALS~1\Temp\MSI117.tmp, Entrypoint: StreamSupportFiles
    MSI (c) (48:70) [09:20:49:223]: Cloaking enabled.
    MSI (c) (48:70) [09:20:49:223]: Attempting to enable all disabled priveleges before calling Install on Server
    MSI (c) (48:70) [09:20:49:223]: Connected to service for CA interface.
    Action ended 9:20:49: StreamSupportFiles.D20239D7_E87C_40C9_9837_E70B8D4882C2. Return value 3.
    MSI (c) (48:A4) [09:20:49:301]: Skipping action: FatalError (condition is false)
    Action ended 9:20:49: INSTALL. Return value 3.
    MSI (c) (48:44) [09:28:50:859]: Destroying RemoteAPI object.
    MSI (c) (48:70) [09:28:50:859]: Custom Action Manager thread ending.

    And here is a section of the _Core(Local).log

    Running: ReportChainingResults at: 2007/0/29 9:28:57
    Error: Action "ReportChainingResults" threw an exception during execution.
    DwLaunchMsiExec() returned : 1603
            Error Code: 0x80070643 (1603)
    Windows Error Text: Fatal error during installation.

      Source File Name: sqlchaining\sqlchainingactions.cpp
    Compiler Timestamp: Thu Sep  1 22:23:05 2005
         Function Name: sqls::ReportChainingResults::perform
    Source Line Number: 2992

    A section of _Core.log:

    Running: LaunchLocalBootstrapAction at: 2007/0/29 9:19:37
    Error: Action "LaunchLocalBootstrapAction" threw an exception during execution.  Error information reported during run:
    "C:\Program Files\Microsoft SQL Server\90\Setup Bootstrap\setup.exe" finished and returned: 1603
    Aborting queue processing as nested installer has completed

    When the install fails, this is the event signature:

    EventType: sql90setup
    P1: unknown
    P2: 0x643
    P3: unknown
    P4: 0x643
    P5: unknown
    P6: unknown
    P7:
    sqlrun.msi@9.00.1399.06

    Friday, February 2, 2007 1:49 PM

Answers

  • Thanks for responding.. I ultimately called Microsoft... They diagnosed it to a DCOM issue.

    It turns out the Registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Ole conflicts with this portion of the install. The rep had me back up (or export) this portion of the Registry, delete the "DefaultAccessPermission" value and associated binary data, and re-run the install.

    Worked great.

    Afterwards, I added the value back.

    Disclaimer: The poster would like to add that this fix was specific to this install, and that neither Microsoft nor the poster will guarantee the results as a result of following this advice for your particular installation.

    Tuesday, February 6, 2007 4:07 PM

All replies

  • \Temp\MSI117.tmp, Entrypoint: StreamSupportFiles
    MSI (c) (48:70) [09:20:49:223]: Cloaking enabled.
    MSI (c) (48:70) [09:20:49:223]: Attempting to enable all disabled priveleges before calling Install on Server
    MSI (c) (48:70) [09:20:49:223]: Connected to service for CA interface.
    Action ended 9:20:49: StreamSupportFiles.D20239D7_E87C_40C9_9837_E70B8D4882C2. Return value 3.
    MSI (c) (48:A4) [09:20:49:301]: Skipping action: FatalError (condition is false)
    Action ended 9:20:49: INSTALL. Return value 3.

    It seems that the sql support files is corrupted. Go to Add/Remove Programs in Control Panel, uninstall SQL Server 2005 Support Files and restart installing. Would you remove it and restart the installation?

    Monday, February 5, 2007 5:00 PM
  • Thanks for responding.. I ultimately called Microsoft... They diagnosed it to a DCOM issue.

    It turns out the Registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Ole conflicts with this portion of the install. The rep had me back up (or export) this portion of the Registry, delete the "DefaultAccessPermission" value and associated binary data, and re-run the install.

    Worked great.

    Afterwards, I added the value back.

    Disclaimer: The poster would like to add that this fix was specific to this install, and that neither Microsoft nor the poster will guarantee the results as a result of following this advice for your particular installation.

    Tuesday, February 6, 2007 4:07 PM
  • Where is the client tools...i don't see them on the CD just the main Server install.

    I want my web developer to have just the business intelligent tools components for vss.....is this on the sql 2005 cd i can't see it

     

    Thanks

    Wednesday, March 21, 2007 11:26 PM
  • 2 days working with this installation and this tiny (but huge) change did it!

    SQL Server 2005 finally installed!!

    Thank you so much JFoushee for posting your findings!!

    Friday, July 31, 2015 4:10 PM