Register-SPWorkflowService - RetryForDurationPolicy Error RRS feed

  • Question

  • I have followed the exact steps from TechNet to install workflow manager 1.0 in my SharePoint 2016 development server, and it looks like all the workflow components are successfully installed. However, when I run Register-SPWorkflowService command, it gives me the following error. I have checked all the services are up and running, and I also have installed Service Bus 1.0 Cumulative Update 1 and Workflow Manager 1.0 Cumulative Update 1. Has anyone seen this and found a fix to it? Appreciate for the help.

    Register-SPWorkflowService : Workflow XAML failed validation due to the following errors:
    Cannot create unknown type '{wf://$Activities}RetryForDurationPolicy'. HTTP headers received from the server - ActivityId: e65530de-b510-4d02-885b-a473c9bb15db.
    NodeId: myservername. Scope: /SharePoint. Client ActivityId :
    At line:1 char:1
    + Register-SPWorkflowService -SPSite
    ""  ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidData: (Microsoft.Share...WorkflowService:
       RegisterSPWorkflowService) [Register-SPWorkflowService], ActivityValidatio
        + FullyQualifiedErrorId : Microsoft.SharePoint.WorkflowServices.PowerShell

    Wednesday, January 18, 2017 2:50 PM

All replies

  • Hi Jimmy,

    Here you go

    Please remember to click Mark as Answer on the answer if it helps you

    Wednesday, January 18, 2017 11:36 PM
  • Hi Jimmy, that error could be due to several issues.

    - Are the Sharepoint and the WFM installed on the sane machine?

    - Are you using an account that was permissions to register?

    - Are you running the Sharepoint PowerShell as an Administrator?

    From the error description, it seems a mismatch of versions on the WFM and Sharepoint, so as a first step, I would recommend that you install the WFM CU3 (install the WFM update and the WFM Client Update).

    You can also take a loo at the below article to check your WFM Farm.

    Please mark as helpful if this was helpful. Thanks & Regards, Jose

    Monday, January 23, 2017 10:06 AM
  • Thanks Lakshmanan Sethu and José Paulo Pendão for the reply.

    I finally got it working. For some reason, "Microsoft.SharePoint.WorkflowServices.Activities.dll" is missing from "TEMPLATE\WorkflowActivities" folder in 16 hive, but it exists in the same structure folder in 15 hive. I copy the dll and put it in the 16 hive folder, then the Register-SPWorkflowService command works.

    • Proposed as answer by Gogcegoz Tuesday, March 21, 2017 11:33 AM
    Monday, January 23, 2017 7:12 PM
  • Cheers man, worked for me
    Tuesday, March 21, 2017 11:33 AM
  • Thanks dear !

    Resolution worked for me.

    Friday, March 24, 2017 3:59 PM