locked
Unit tests take one minute to start RRS feed

  • Question

  • I am using Visual Studio Enterprise 2015 Version 14.0.25431.01 Update 3.

    Whenever I run or debug a unit test, it takes about 60 seconds after it is finished compiling to start executing the unit test.  Sometimes the unit test will start immediately, but most of the time the delay occurs.

    Anybody know how to resolve this?

    Thursday, January 26, 2017 9:06 PM

Answers

  • Hi Mimimzungu,

    Please clean and rebuild your solution in the solution explorer windows.

    (1) Disable the option "Enable the Visual Studio hosting process" under Project property->Debug. Note: Not only the test project, please also disable this option for the project you want test.

    (2) Disable the Microsoft symbols server under TOOLS->Options->Debugging->Symbols.

    (3) Please also disable the "Enable IntelliTrace" under TOOLS->Options->IntelliTrace. Disable "Enable Diagnostic Tools while debugging", check it again.

    Best Regards,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by Mimimzungu Thursday, February 2, 2017 12:29 AM
    Monday, January 30, 2017 6:36 AM

All replies

  • Hi Mimimzungu,

    According to your description, please create a new unit test project ant run the test method to see whether has the same delay issue.

    If not, before you run the test, please build it and then run it to see the results.

    Sincerely,

    Oscar


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, January 27, 2017 12:35 AM
  • I created a brand new project with a new unit test, and am still having the same issues.  Please see video that illustrates symptom: https://youtu.be/Ky5zS3v7rFs 
    Friday, January 27, 2017 7:03 PM
  • Hi Mimimzungu,

    Please clean and rebuild your solution in the solution explorer windows.

    (1) Disable the option "Enable the Visual Studio hosting process" under Project property->Debug. Note: Not only the test project, please also disable this option for the project you want test.

    (2) Disable the Microsoft symbols server under TOOLS->Options->Debugging->Symbols.

    (3) Please also disable the "Enable IntelliTrace" under TOOLS->Options->IntelliTrace. Disable "Enable Diagnostic Tools while debugging", check it again.

    Best Regards,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by Mimimzungu Thursday, February 2, 2017 12:29 AM
    Monday, January 30, 2017 6:36 AM