none
Visual Studio Professional 2013 shows IIS Express error while Debugging

    Question

  • Hi, I am getting this error while running my ASP.Net 4.5 application from Visual Studio Professional 2013.
    Unable to start program "C:\Program Files (x86)\IIS Express\iisexpress.exe". Access is denied.

    Below is my system details:

    OS: Windows 10
    IIS: IIS 8 Express
    IDE: Visual Studio Professional 2013
    And I am running the Visual Studio in Admin mode only.

    I went through below steps as well few times:
    I deleted IISExpress folder from 'C:\Users\<my-user-id>\Documents\' multiple times and tried again. But still no luck. Getting same error.
    Re-installed Visual Studio
    Re-installed IIS Express

    Kindly help me to fix the issue.


    Satheesh Subramanian



    Friday, June 17, 2016 5:00 AM

Answers

  • Hi Satheesh Subramanian,

    According to the error message, this problem should be caused by the permissions for Visual Studio and IIS.

    Please try open the iisexpress.exe under the path "C\Program Files (x86)\IIS Express\" directly to check whether it can be opened successful. And please check the permissions for this issue to make sure it can be opened by administrator.

    In addition, please try create another user and let it has administrator permission. It can help us confirm whether this problem caused by current user.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, June 20, 2016 2:48 AM
    Moderator