none
Kinect xbox one only recognized as usb generic hub RRS feed

  • Question

  • Hello,

    I bought a kinect v2 (xbox one) and the USB dongle to plug it into my Windows 10 PC.

    I want to do 3D scans.

    I installed the SDK v2.0_1409 but the kinect is only recognized as a usb generic hub and a superspeed usb generic hub.

    I ran the Kinect V2 configuration verifier and I have the following result:

    Everything is green except usb controller, kinect connected and verify kinect depth...

    I checked my usb hub and I confirm it's 3.0.

    My computer is a HP elitedesk 800 mini g2.

    I also tried on a dell latitude 5580 and I have the same behavior.

    I tried rebooting, reinstalling, plugin, unpluging and various combination of the previous options.

    Is there a way to know if the kinect is properly connected (led, sound...).

    What is weird is that when I plug/unplug the kinect to/from the usb dongle, my computer do not detect any change.

    I went on various forum and read many threads. I found out there was a new version of kinect drivers but I couldn't put my hands on it for 3d scan 2.0.46.0 or higher.  The driver version seems to be 2.2.1610.17001.

    I also installed 3d scan 2.0.47.0

    Thank you all for your support.

    Wednesday, August 29, 2018 7:07 PM

All replies