locked
URL rewrite installation failing due to signature verification failure RRS feed

  • Question

  • User-2034328377 posted

    Hi,

    URL rewrite installation is falling on Server 2016 azure VMs. Reason "Downloaded file failed signature verification and may have been tampered with"

    EULA: 'URL Rewrite 2.1', which is owned by 'Microsoft', will be downloaded from 'http://download.microsoft.com/download/D/D/E/DDE57C26-C62C-4C59-A1BB-31D58B36ADA2/rewrite_amd64_en-US.msi'.
    The license agreement to 'URL Rewrite 2.1' is available at 'http://download.microsoft.com/download/D/D/E/DDE57C26-C62C-4C59-A1BB-31D58B36ADA2/URL%20REWRITE%20MODULE-Final-EN.rtf'.
    Accepted EULA.
    Starting Installation
    Started downloading products...
    Started downloading: 'URL Rewrite 2.1'
    Started installing Products...
    Started installing: 'IIS: WAS Process Model'
    . .. Downloaded: 'URL Rewrite 2.1'
    Install completed (Failure): 'URL Rewrite 2.1'
    UrlRewrite2 : Failed.
    Downloaded file failed signature verification and may have been tampered with

    Thanks,

    Sujith

    Monday, September 17, 2018 2:29 AM

All replies

  • User1881077623 posted

    Hi,

    I'm also experiencing an issues trying to install the current version of URL ReWrite

    I've tried installing via Web Platform Installer and via downloading the x64 version of MSI but get an error when trying to install on Windows Server 2016.

    I'm running Build 14393.2485 if that's on any relevance.

    Looking at the digital signature on the MSI it appears a new version was released on September 12th 2018 as that is when this release was timestamped, so it appears the issue seems to be specific to this updated release.

    I can't seem to find a download any way to download the June 2017 release as all the links download the current release.

    Les

    Monday, September 17, 2018 6:25 AM
  • User694382612 posted

    Hello Sujith Tummala,

    I could reproduce the issue like you.

    After I comparing the installer file I download last month and the installer I donwload today, I think URL rewrite team maybe updated the download file incorrectly.

    For current workaround, I will upload the isntaller file I download last month, you could try to get it from

    https://1drv.ms/u/s!ArC0gnwxLv5qhykOizu8oapmWxKL

    We will continue focus on the issue. If it is fixed, we will inform you.

    Best Regards,

    Terry

    Monday, September 17, 2018 10:03 AM
  • User1881077623 posted

    Terry,

    Thanks for posting a link to a copy of the June 2017 installer.

    That installer worked for me.

    Les

    Monday, September 17, 2018 9:41 PM
  • User-481904819 posted

    Hi Terry

    I just wanted to extend my thanks to you too.

    I had encountered exactly the same issue as Les, but the previous version you kindly posted above worked <g class="gr_ gr_84 gr-alert gr_gramm gr_inline_cards gr_run_anim Grammar only-ins replaceWithoutSep" id="84" data-gr-id="84">first</g> time.

    Think some improved testing might be needed before the next release!

    Kind regards

    Ian

    Monday, September 17, 2018 10:55 PM
  • User470041118 posted

    Hello Terry,

    Do you have some news about this issue?

    Would you mind putting the previous installer link for the spanish language?

    Best regards,

    Ricardo

    Tuesday, September 18, 2018 12:25 PM
  • User-2145974911 posted

    Thank you Terry Peng, i also solvented this problem with you link.

    Tuesday, September 18, 2018 1:24 PM
  • User-2046281398 posted

    Same issue here. We are using the following link:

    http://download.microsoft.com/download/C/F/F/CFF3A0B8-99D4-41A2-AE1A-496C08BEB904/WebPlatformInstaller_amd64_en-US.msi

    Log:Starting Installation
    Started downloading products...
    Started downloading: 'URL Rewrite 2.1'
    Downloaded: 'URL Rewrite 2.1'
    Install completed (Failure): 'URL Rewrite 2.1'
    UrlRewrite2 : Failed.
    Downloaded file failed signature verification and may have been tampered with

    Does anyone have the previous version of this available? Is there any way to flag this with Microsoft to get an ETA on the official links being fixed?

    Wednesday, September 19, 2018 8:31 AM
  • User-481904819 posted

    Hi Andrew

    See Terry's initial reply for the link (third item, dated: Sep 17, <g class="gr_ gr_13 gr-alert gr_gramm gr_inline_cards gr_run_anim Punctuation only-ins replaceWithoutSep" id="13" data-gr-id="13">2018</g> 10:03 AM)

    Kind regards

    Ian

    Wednesday, September 19, 2018 8:39 AM
  • User-2046281398 posted

    Hi Ian,

    Apologies probably wasn't clear from the post, I have already tried it but it failed in our build still. My understanding is this is because its a different file that is being downloaded.

    Terry was using: rewrite_amd64_en-US.msi

    Our build is using: WebPlatformInstaller_amd64_en-US.msi

    I'm currently trying to get access to current live servers to get the old version of this file off them, upload it and download as part of our build from the new location. Was just hoping someone could possibly link it to me in here quicker than I can do this :)

    Thanks,

    Andrew Robinson

    Wednesday, September 19, 2018 8:55 AM
  • User-2046281398 posted

    Think I've sussed it out, our build does a powershell install of the WebPlatformInstaller, which reaches out to download the Url Rewrite module and presumably gets the latest version. I will start working on editing the powershell to download just Terry's file - just need to figure out the powershell for a quiet install and accept agreements and mod those lines too.

    Wednesday, September 19, 2018 9:10 AM
  • User-481904819 posted

    Hi Andrew

    The MSI you mention is actually the setup package for the Web Platform Installer itself and doesn't include the URL Rewrite installer within that. You would install the WPI first and then use that to install the URL rewrite package.

    You can download the latest WPI setup package from here: https://go.microsoft.com/fwlink/?LinkId=287166 (x64 version)

    Having built a new server three days ago, I know the latest WPI setup package to be working, but then encountered the URL rewrite issue discussed above. The error messages you posted list the same error regarding the URL rewrite package, there is no mention of an issue with the WPI package.

    I would recommend downloading the latest WPI package and combining that in your build with the URL rewrite package kindly provided by Terry above as this has resolved the issue for both me and others in this post.

    Kind regards

    Ian

    Wednesday, September 19, 2018 9:10 AM
  • User-481904819 posted

    And you'd already come to a similar conclusion, excellent news!

    Kind regards

    Ian

    Wednesday, September 19, 2018 9:14 AM
  • User-1924990629 posted

    Hmm, I use chocolatey to provision my servers and they are failing on the same thing. Hope this is fixed at source soon!

    Wednesday, September 19, 2018 9:23 AM
  • User-2046281398 posted

    Is there any way to perform a headless install of the link by Terry? Our scenario is we are creating a base image (via Packer) which is used in an auto scaling group on AWS. A manual install is not an option, copies will be rolled up and torn down as needed. All releases to our dev environment are blocked by this issue, and thus no updates can go out to staging or production either.

    What we used to do (and hopefully can get back to doing):

    Invoke-WebRequest 'http://download.microsoft.com/download/C/F/F/CFF3A0B8-99D4-41A2-AE1A-496C08BEB904/WebPlatformInstaller_amd64_en-US.msi' -OutFile c:/msi/WebPlatformInstaller_amd64_en-US.msi

    Start-Process 'c:/msi/WebPlatformInstaller_amd64_en-US.msi' '/qn' -PassThru | Wait-Process

    Set-Location 'C:/Program Files/Microsoft/Web Platform Installer'; .\WebpiCmd.exe /Install /Products:'UrlRewrite2' /AcceptEULA /Log:c:/msi/WebpiCmd.log

    I have currently copied Terry's link, added it to an S3 location to be put on the disk at image creation time. However, I cannot get a headless install to work with:

    Start-process msiexec.exe -Wait -ArgumentList "/i C:/msi/rewrite_amd64_en-US.msi /qn /passive /L*V `"C:/msi/log.txt`""

    So I am currently digging into the documentation at:

    https://docs.microsoft.com/en-us/iis/install/web-platform-installer/web-platform-installer-v4-command-line-webpicmdexe-rtw-release

    I am going to attempt creating an offline cache, then hopefully overwrite the offline Url Rewrite file with Terry's, then attempt an offline install. Sound like an idea? No idea if it will be that simple - hasn't been so far!

    Wednesday, September 19, 2018 12:49 PM
  • User-1272477322 posted

    Any update from the URL Rewrite team on this issue?

    Wednesday, September 19, 2018 3:57 PM
  • User-1084200161 posted

    This should be resolved now.. it's been rolled back and now  just CDNs need to reflect this change (roll-back)...

    Wednesday, September 19, 2018 4:26 PM
  • User-1272477322 posted

    Can you post the download URL for the English x64 MSI so we are certain we are attempting the correct URL?

    Wednesday, September 19, 2018 4:51 PM
  • User-1084200161 posted

    sorry, just got an update that it's still being actively worked on..  looks like there's a bit of a delay in getting the updated (rolled back installer) up on the download center..

    EDIT: I just tried on two different machines and it worked on both (they were on different networks).. downloading from:

      http://download.microsoft.com/download/D/D/E/DDE57C26-C62C-4C59-A1BB-31D58B36ADA2/rewrite_amd64_en-US.msi

    install was successful.

    Noah, can you try again?

    Wednesday, September 19, 2018 9:15 PM
  • User-1924990629 posted

    I can confirm it works fine for me now. Thanks for sorting it out so quickly :)

    Thursday, September 20, 2018 6:52 AM
  • User481554606 posted

    Could anybody please provide URLs for the updated localized versions? At least the de_DE version is f*cked up as well

    EDIT: Seems like installing the en_US version apparently still leads to localized installs. So using the en_US works, but is counterintuitive. But the WebPlatform Installer still fails on de_DE

    Thursday, September 20, 2018 10:38 AM
  • User-1883517295 posted

    Can confirm the link that Radomir posted worked perfectly for me after struggling with this for a week.  Thank you!

    Thursday, September 20, 2018 8:54 PM
  • User-978300080 posted

    The Japanese x64 link is still wrong.

    Please correct the links of the localized versions too.

    Sunday, September 23, 2018 12:34 PM
  • User1822081225 posted

    DownloadManager Error: 0 : WinInet download error. Uri: https://file.ac/kLa3HIp4zBg/cclogo.png, Error: System.Net.WebException: Url 'https://file.ac/kLa3HIp4zBg/cclogo.png' returned HTTP status code: 404
       在 Microsoft.Web.PlatformInstaller.ManagedWinInet.OpenUrlAndFollowRedirects(Uri& uri, IntPtr& hInetFile)
       在 Microsoft.Web.PlatformInstaller.ManagedWinInet.DownloadFile(Uri uri, String fileName, String& contentDispositionFileName)
       在 Microsoft.Web.PlatformInstaller.UI.DownloadServiceImplementation.DownloadFile(Uri uri, String filePath)
    DownloadManager Information: 0 : Adding product URL 重写工具 2.0 (UrlRewrite2) to cart
    DownloadManager Error: 0 : WebClient download error. Uri: http://www.websitepanel.net/files/wsp_screenshot.png, Error: System.Net.WebException: 操作超时
       在 System.Net.WebClient.DownloadFile(Uri address, String fileName)
       在 Microsoft.Web.PlatformInstaller.UI.DownloadServiceImplementation.DownloadFile(Uri uri, String filePath)
    DownloadManager Information: 0 : Adding product 'UrlRewrite2'
    DownloadManager Information: 0 : Setting current install to 1
    DownloadManager Information: 0 : Starting install sequence
    DownloadManager Information: 0 : Downloading file 'http://download.microsoft.com/download/E/A/9/EA9F19BC-0EEB-49C9-B32D-56852BBE56DA/rewrite_amd64_zh-CN.msi' to: C:\Users\Administrator\AppData\Local\Temp\2\tmpABE0.tmp
    DownloadManager Information: 0 : Content-disposition header: attachment
    DownloadManager Information: 0 : Number of bytes downloaded over the internet: '5865472'
    DownloadManager Information: 0 : Number of bytes after possible decompression: '5865472'
    DownloadManager Information: 0 : File 'C:\Users\Administrator\AppData\Local\Microsoft\Web Platform Installer\installers\UrlRewrite2\325176BFC334E2A2A5FA0226C4EE4DA557A5013B\rewrite_amd64_zh-CN.msi' already exists, deleting old copy of the file
    DownloadManager Information: 0 : Moving downloaded file 'C:\Users\Administrator\AppData\Local\Temp\2\tmpABE0.tmp' to: C:\Users\Administrator\AppData\Local\Microsoft\Web Platform Installer\installers\UrlRewrite2\325176BFC334E2A2A5FA0226C4EE4DA557A5013B\rewrite_amd64_zh-CN.msi
    DownloadManager Error: 0 : Signature verification failed on downloaded file. URL: http://download.microsoft.com/download/E/A/9/EA9F19BC-0EEB-49C9-B32D-56852BBE56DA/rewrite_amd64_zh-CN.msi. File location: C:\Users\Administrator\AppData\Local\Microsoft\Web Platform Installer\installers\UrlRewrite2\325176BFC334E2A2A5FA0226C4EE4DA557A5013B\rewrite_amd64_zh-CN.msi. File size: 5728 kb
    DownloadManager Information: 0 : Product URL 重写工具 2.0 done install completed
    DownloadManager Information: 0 : Increasing current install to 2
    DownloadManager Information: 0 : Product: UrlRewrite2, Install Status: InstallCompleted-Failure, Install Time: 00:00:00

    Friday, September 28, 2018 10:08 AM