locked
OCR library not working now with Windows Runtime.

    Question

  • I worked on OCR library 2 months back. I was amazed with its performance, and made two apps based on this which are on windows store. But now it seems not working anymore.Then I tried to run the Microsoft OCR Library Sample app, it is also not working now.It works in debug mode only.I ran Windows certifications test and it showed the error that It is using API which is not part of windows SDK for windows apps.
    Friday, January 9, 2015 2:04 PM

All replies

  • Hi Pooja_B

    Any more information you can provide to us, for instance which API is not part of Windows SDK for Windows Store Apps? OcrEngine class does not mention anything that this API is not working.

    Please follow the instruction by http://msdn.microsoft.com/en-us/library/windows/apps/dn643522.aspx and install the package again to see if the same issue happens.

    • In Visual Studio, select PROJECT | Manage NuGet Packages.
    • In the Online section, select nuget.org. Search for Microsoft.Windows.Ocr.
    • Click Install.
    • Select BUILD | Configuration Manager to change the build configuration of your project from AnyCPU to x86, x64, or ARM
    • If Intellisense does not work after you have installed the NuGet package, unload and reload the Visual Studio project. In Solution Explorer, right-click the project and select Unload Project. Then right-click the project again and select Reload Project.

    I did not counter any problem when using this namespace and running the sample.

    --James


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, January 12, 2015 2:13 AM
    Moderator
  • Hi James

    I tried once again with the sample app as you have suggested. It works fine but when I create the app packages and run a certification test it get failed every time.

    Here are the images for the errors

    https://drive.google.com/folderview?id=0B04sINmDdFfASGc2SDlhS1dJTHc&usp=sharing

    My apps on windows store which are not working now.

    http://apps.microsoft.com/windows/en-us/app/capture-translate/b43a22e1-44ce-469b-878c-bbde8cc3951f

    http://apps.microsoft.com/windows/en-us/app/photo2text/d0a3cd74-d04b-4c15-a14b-ff84cf9b1600

    Monday, January 12, 2015 7:21 AM
  • Hi Pooja,

    In the future please post the text of the error in your thread. It is much easier to help you if you provide full information.

    It looks like you are running into a known issue. It shouldn't affect certification, only the WACK when run locally. Please see http://support.microsoft.com/kb/3026757 .

    --Rob

    Monday, January 12, 2015 7:26 AM
    Owner
  • Hi Rob,

    I am really unable to rebuilt the packages for my previous apps which are on store.

    I am getting this errors

    An exception of type 'System.TypeLoadException' occurred in CaptureNTranslate.Windows.exe but was not handled in user code

    Additional information: Requested Windows Runtime type 'WindowsPreview.Media.Ocr.OcrEngine' is not registered.

    The same code was working perfectly two months before

    Monday, January 12, 2015 7:37 AM
  • Those errors aren't related to the ones you mentioned previously.

    As Jamles suggested, make sure you have the nuget files updated and everything current in and installed in your project. The errors sounds like that may not be the case.

    If you need more help you'll need to provide more details. Can you reproduce the problem in a new minimal sample using the OcrEngine control?

    Monday, January 12, 2015 9:42 PM
    Owner
  • Hello Rob,

    I already tried many thing, I built a new minimal sample which was working fine but when i run WACK test it also get failed. and if I try to add more code the app didn't even start.

    Here is my code for OCR . It will be so helpful if you test this sample code and run Windows certification tests on this (Microsoft OCR Library Sample app is also failed in WACK test). I am pretty much sure that there is some problem with that.

    https://drive.google.com/file/d/0B04sINmDdFfAMTZGek92YXpxNjg/view?usp=sharing

    Thanks.

    Wednesday, January 14, 2015 2:07 PM