none
Can't trigger autoscaling from availability test in Azure RRS feed

  • Question

  • Situation

    I have a simple availability test that just consists to call my home url every 5 minutes This works fine.

    I want to trigger autoscaling depending on the time this ping takes to respond.

    What I did

    So, for testing purpose, I completed the controller code by:

    
    Thread.Sleep(2000)

    Then in Monitor/Autoscale I created a rule for my service plan resource

    I only build a scale out rule configured like:

    • Resource type: availability test
    • resource: my test name
    • metric name: Response time
    • time agregation: average
    • duration: 5
    • time grain: 5 minutes
    • time grain statistic: average
    • operator >=
    • threshold: 1
    • operation: increase count by
    • increase count: 3
    • cool down: 5

    My problem

    I am not sure about the unit of the theshold. But even if it is min it should trigger an autoscalling. But I have never seen any scaling.

    My questions

    What might be wrong in my configuration? I tested that autoscaling works fine if I monitor by number of request on my web site.

    Thank you



    Thank you!

    Friday, August 9, 2019 9:51 AM

Answers

  • It seems like there may be an issue with the auto scaling rules when it comes to availability tests so I will reach out to the product team about that. I was able to get the rule working that I believe you want by modifying it slightly.

    The key was changing the type of resource from Availability Test to Application Insights and accessing the test duration through there. Instead of the "Count" threshold it becomes "Milliseconds" which is the metric you are looking to test against.

    You can also see details about evaluations by turning on the diagnostic logs in your scaling settings. There is an option for "AutoscaleEvaluations" which will contain values for the metric that is being evaluated any why the system took or didn't take action.

    • Marked as answer by Frédo Monday, August 12, 2019 10:26 PM
    Monday, August 12, 2019 6:32 PM
    Moderator

All replies

  • It seems like there may be an issue with the auto scaling rules when it comes to availability tests so I will reach out to the product team about that. I was able to get the rule working that I believe you want by modifying it slightly.

    The key was changing the type of resource from Availability Test to Application Insights and accessing the test duration through there. Instead of the "Count" threshold it becomes "Milliseconds" which is the metric you are looking to test against.

    You can also see details about evaluations by turning on the diagnostic logs in your scaling settings. There is an option for "AutoscaleEvaluations" which will contain values for the metric that is being evaluated any why the system took or didn't take action.

    • Marked as answer by Frédo Monday, August 12, 2019 10:26 PM
    Monday, August 12, 2019 6:32 PM
    Moderator
  • Thank you, it's working fine

    Could you please tell me what does 'Test result' relates to?


    Thank you!

    Monday, August 12, 2019 10:32 PM
  • In this case there is only one result. If you were using a multi-step web test there would be multiple results and you need to choose which ones you are going to use in the auto scaling rule.
    Tuesday, August 13, 2019 5:02 PM
    Moderator