locked
Developing Database using Visual Studio 2013 backend is ms access2016.accdb RRS feed

  • Question

  • Hi,

    I have develop a sample database with VS2013 with back end is MS Access2016.accdb. when i run the database with Visual Studio 2013 everything works find, like crystal report search is working. It displays data i search in the textbox from the crystal report,But when i use install shield and compile the database for setup with .exe, then the crystall report Search in the textbox did not display data i search in the crystal report. It didn't display any data at all.

    Can anybody heip me here. Your help will much appreciated. 

    Friday, June 28, 2019 5:37 AM

All replies

  • Hello,

    We will need more information for instance

    • Is the app installed on another computer or did you simply install on your computer.
    • How are data operations done e.g. using TableAdapter method or another method
    • What else does the app do besides using Crystal reports, is data shown in other controls e.g. TextBoxes, DataGridView etc.
    • Where is the database located in the app folder or another folder.
    • Do you have any try-catches with empty catches
    • Is the computer installed with your app the same OS e.g. Windows 10 and is the computer on or off a network

    Please remember to mark the replies as answers if they help and unmarked them if they provide no help, this will help others who are looking for solutions to the same or similar problem. Contact via my Twitter (Karen Payne) or Facebook (Karen Payne) via my MSDN profile but will not answer coding question on either.

    NuGet BaseConnectionLibrary for database connections.

    StackOverFlow
    profile for Karen Payne on Stack Exchange

    Friday, June 28, 2019 9:44 AM
  • Hi Karen Payne,

    -The application is installed on another computer.

    - And operations is done using methods.

    - Data is showing in Textboxes and Datagridview.

    - The database is located in the app folder.

    - I have try-catches.

    - yea the computer installed with my app the same Operating system.

    - the computer is a standalone not a network.

    ______________________________________________________

    For your Information:

    The application is in the visual studio 2013 folder, which in the same folder has a bin and debug folder, that the database located inside and the app. I have sample datas' already entered inside. when i search sample data they displayed in the crystal report,but when i entered new data and try to search it, does not display in the crystal report. that was after i set it up using installed shield called SSE.

    Thank you in advance.

    Monday, July 1, 2019 5:54 AM