none
Kinect v1 SDK doesn't work well with Unity 5 RRS feed

  • Question

  • Kinect SDK 1.8 has a major issue, when working together with Unity 5. On many older PCs and laptops, after working normally for 1-2 minutes, any Kinect-stream's GetNextFrame() starts returning error code 0x83010006 (DeviceNotGenuine), which effectively causes the scene to freeze. The Unity support staff has researched this issue some time ago. They came to the conclusion that the problem is in the Kinect SDK or driver. I can provide you all the information I know on this issue, if you like. And I know Kinect v1 and its SDK are quite old now, but they are still very popular and used often in various VR setups. Do you have any plans to fix this issue, or at least provide a workaround?
    Thursday, October 29, 2015 1:31 PM

All replies

  • Any update regarding this issue? I have been trying to find a workaround as well. 
    Tuesday, December 22, 2015 1:14 AM
  • Not really. After waiting for two months now, I don't think we will get any official support regarding Kinect v1 or SDK 1.8. I'm posting the updates on this issue here, if you're interested. Have you found anything useful?


    • Edited by rfilkov Tuesday, December 22, 2015 11:39 AM open link in new window
    Tuesday, December 22, 2015 11:37 AM
  • Unfortunately all my different attempts have failed using Unity 5 with the same error, DeviceNotGenuine. 
    Tuesday, December 22, 2015 5:45 PM
  • FYI: The best workaround for this issue, as reported so far by different users, is as follows: Uninstall all Kinect-v1 related packages (SDKs, drivers, OpenNI, NiTE, Zugfu, etc.), restart, install Kinect SDK 1.8 only, and restart again.

    • Edited by rfilkov Wednesday, August 10, 2016 4:07 PM
    Wednesday, August 10, 2016 4:07 PM
  • My setup is Kinect (Xbox 360 version) + Kinect SDK v1.8.0 running on Windows 7 64-bit and I'm also experiencing the DeviceNotGenuine error. I believe this is not Unity 5 specific because this also happens with the demos contained in the official Kinect Developer Toolkit v1.8.0. To reproduce this, first trigger the exception in Unity 5, then try running one of the demos from the Toolkit (e.g. Kinect Explorer-D2D). After a couple of minutes the demo just stops all of a sudden and the device status window changes state from "Connected" to "NotGenuine".

    As suggested by rfilkov, I tried to uninstall all Kinect-related stuff, restart the machine, install Kinect SDK 1.8 only, and then restart again, but the error persists (did this quite a few times now).

    Tuesday, February 7, 2017 4:24 PM