none
Enrollment process in Windows 10 Mobile Anniversary Update RRS feed

  • Question

  • I develop MDM solution for our company and I try enrollment process with Windows 10 Mobile with Anniversary Update (insider program).

    In Anniversary update there are couple of changes in enrollment process which makes our actual solution non-functional. The problem is a lot of our employees use email on domain like outlook.com or gmail.com.

    In Windows 10 (without Anniversary), in case server on domain derivated from email didn't have implemented enrollment functionality, system prompt dialog to set server address manually. For example if I use email hovado@gmail.com I was prompt to set server address.

    This doesn't work anymore in Anniversary update. If I put email on outlook.com or gmail.com system just say "You can't setup Windows with this email address. Try another one or set up Windows without connected services." and show field to write password. And what is more important - user can't change Enrollment server address (sry, I can't send you screenshot, because I have not verified account). It is big problem for our company, because a lot of our employees use their private email address for device managment enrollment. 

    Is there any way to register W10M device with Anniversary update to device managment with outlook.com or gmail.com addresses? How to force system manually set enrollment server address?

    Tuesday, July 19, 2016 11:06 AM

Answers

  • If you are on build 1607 when you navigate to Settings > Accounts > Work or School Access you will notice few extra options at the bottom. One of them will be "Enroll only into Device Management". That is the option you are looking for. In case you do not have the option, open your Edge browser and type in the following url :
    ms-device-enrollment:?mode=mdm
    This will launch the Add Account App in the MDM mode and will not ask for an O365 login.
    • Marked as answer by hovado Monday, October 17, 2016 12:21 PM
    Thursday, October 13, 2016 9:38 AM

All replies

  • Same problem here.

    In earlier versions (build < 10.0.14393) we could enter server adress manually. No we cannot enroll w10 devices any more.

    How can we develop for MDM now? our testemail accounts cannot resolve to our development machines without entering the servername manually.

    Please microsoft help or tell us how to do this now.

    thanks

    Tuesday, July 26, 2016 12:52 PM
  • Workaround: enter in the user textbox something like aklsjsal@asjlsanls.com. The connection will fail, and you will see a textbox where you can put the MDM url bellow the username textbox.

    • Proposed as answer by WillemHT Friday, August 26, 2016 6:04 AM
    • Unproposed as answer by hovado Wednesday, September 7, 2016 10:32 AM
    Wednesday, August 24, 2016 2:26 PM
  • You are right, but if I correct email after that, it will redirect me again to page without my specified server address. So only solution now is to use fake emails, which barely acceptable for me :(...
    Friday, August 26, 2016 12:50 PM
  • If you are on build 1607 when you navigate to Settings > Accounts > Work or School Access you will notice few extra options at the bottom. One of them will be "Enroll only into Device Management". That is the option you are looking for. In case you do not have the option, open your Edge browser and type in the following url :
    ms-device-enrollment:?mode=mdm
    This will launch the Add Account App in the MDM mode and will not ask for an O365 login.
    • Marked as answer by hovado Monday, October 17, 2016 12:21 PM
    Thursday, October 13, 2016 9:38 AM
  • Thank you very much, finally solution that works...

    This approach also solve problem in last 1607 build (10.0.14393.321). When i register device in classic way (through settings -> enroll button, put email on discovery domain and than fill in domain+name and password) device send domain+username in user field and email on discovery domain in password field instead of password. When I register evice with your approach (using link from edge), it works properly.

    Monday, October 17, 2016 12:27 PM