locked
Can't get ASP Local Detailed Error Messages sent to server's local browser RRS feed

  • Question

  • User1889995255 posted

    As per this thread, I don't seem to be able to access detailed messages from the server's local browser.  We have always used this to isolate the issues in our ASP code, and as noted at the end of the post.

    I do currently have three or four servers that have this configuration working without problems and can't work out why it isn't working on this new build.

    The two commands that I run to set up the server are:

    %windir%\system32\inetsrv\appcmd set config -section:asp -scriptErrorSentToBrowser:true


    %windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/httpErrors -errorMode: DetailedLocalOnly

     

    Edit: I've noticed that I also have Enable Server-side debugging

    Friday, September 28, 2012 10:29 AM

All replies

  • User-76669496 posted

    Hi,

    You did not mention if you've disabled 'Show Friendly Errors' in your browser.

    http://technet.microsoft.com/en-us/library/cc778248(v=ws.10).aspx

     

    In the web.config I would temporarily set custom errors to off.

    Wednesday, October 3, 2012 3:00 PM
  • User744767459 posted

    Hi,

    The appcmd command commit to applicationhost, please also make sure that "scriptErrorSentToBrowser" and "httpErrors " have not been overwritten in site level, sub application or file level. To verify this, please run following command:

    %windir%\system32\inetsrv\appcmd list config http://localhost/test/test.asp  -section:asp

    Note: please replace the http://localhost/test/test.asp with the actual URL of your asp page. Thanks.

    Friday, October 5, 2012 4:45 AM
  • User1889995255 posted

    Hi Peter,

    People actually still use IE?  I'm not using IE, yes I saw references to that issue and ignored it.

    Thank you for checking but this isn't my issue here.

    Monday, October 8, 2012 6:08 AM
  • User1889995255 posted

    Hi Leo,

    I should have entered this query under my Technet ID as I can see an appreciable difference in time to respond :)

    Here is the output for a site on the problem server.  As you can see the settings exist at the site level

     C:\>%windir%\system32\inetsrv\appcmd list config somedomain.co.uk -section:asp
    <system.webServer>
      <asp appAllowDebugging="true" enableParentPaths="true" scriptErrorSentToBrowser="true">
        <session />
        <comPlus />
        <cache diskTemplateCacheDirectory="%SystemDrive%\inetpub\temp\ASP Compiled Templates" />
        <limits bufferingLimit="104857600" maxRequestEntityAllowed="104857600" />
      </asp>
    </system.webServer>


    I usually set these serverwide on setup with my iis setup script.  I run the following as part of my script:

    %windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/httpErrors /errorMode:DetailedLocalOnly
    %windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/asp /scriptErrorSentToBrowser:true


    For clarification, this server is an AWS instance running on Server 2008 R2 Datacenter edition.
    Application pools are running in 32bit mode.

    I have one other similarly set up webserver, but that one is working even with near exactly the same configuration as far as I can discern.  The three other Windows servers I administer have Plesk installed on them, but they too do not have this issue with displaying errors locally.

    Monday, October 8, 2012 6:28 AM